Add composer.json #21

Merged
merged 1 commit into from Apr 3, 2012

Conversation

Projects
None yet
3 participants

No description provided.

Could someone consider this PR please ? Thank you !

@EmmanuelVella I can be wrong but I believe that you don't need this, because packgist auto track all branches and tags into the repository.

Can someone confirm this?

The main problem is that the autoload namespace is not the same than the master branch (Doctrine\Bundle\MigrationsBundle => Symfony\Bundle\MigrationsBundle)

+ "require": {
+ "php": ">=5.3.2",
+ "symfony/symfony": ">=2.0,<2.1",
+ "doctrine/migrations": "*"
@stof

stof Mar 28, 2012

Member

you should not use unbound constraints whenever possible as tags should not contain them (we cannot release something that requires knowing the future as Chuck Norris is not part of the team)

@stof I'm sorry, could you be more explicit ? Thanks ;)

Member

stof commented Mar 29, 2012

* does not have an upper bound. this means that you are saying that the 2.0 branch is compatible with any version of the library, including versions that are not yet released (or not even yet planned in dev's minds)

Thank you, for the precisions. The doctrine migration lib only has a master branch (and no tags), so I don't know what to put as upper bound !

stof added a commit that referenced this pull request Apr 3, 2012

@stof stof merged commit 37530d4 into doctrine:2.0 Apr 3, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment