Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Fixing dependencies as of latest doctrine tags

  • Loading branch information...
commit 57ea94d07a3cc3fab085cccdca14a61a8fa6dbea 1 parent a308da6
@Ocramius Ocramius authored
Showing with 4 additions and 4 deletions.
  1. +2 −2 README.md
  2. +2 −2 composer.json
View
4 README.md
@@ -26,9 +26,9 @@ Installation of this module uses composer. For composer documentation, please re
```json
{
- "minimum-stability": "dev",
+ "minimum-stability": "alpha",
"require": {
- "doctrine/doctrine-orm-module": "dev-master"
+ "doctrine/doctrine-orm-module": "0.*"
}
}
```
View
4 composer.json
@@ -33,7 +33,7 @@
],
"require": {
"php": ">=5.3.3",
- "doctrine/doctrine-module": "dev-master",
+ "doctrine/doctrine-module": "0.*",
"doctrine/orm": ">=2.3-dev,<2.5-dev",
"doctrine/dbal": ">=2.3-dev,<2.5-dev",
"doctrine/migrations": "dev-master",
@@ -45,7 +45,7 @@
"suggest": {
"zendframework/zend-developer-tools": "zend-developer-tools if you want to profile operations executed by the ORM during development"
},
- "minimum-stability": "dev",
+ "minimum-stability": "alpha",
"autoload": {
"psr-0": {
"DoctrineORMModule\\": "src/",

7 comments on commit 57ea94d

@jhuet

Because of this change, i can't require both doctrine-mongo-odm-module and doctrine-orm-module at the same time as the ODM module is still requiring doctrine-module dev-master.

@Ocramius
Owner

@jhuet would * be helpful? The ODM module sure needs a tag too.

@jhuet

@Ocramius, i think it would do it yes.

@Ocramius
Owner

@jhuet what's your current composer.json?

@jhuet
[...]
"minimum-stability": "dev",
"require": {
    "php": ">=5.3.3",
    "zendframework/zendframework": "dev-master",
    "doctrine/doctrine-mongo-odm-module": "dev-master",
    "doctrine/doctrine-orm-module": "dev-master",
    "zf-commons/zfc-base": "dev-master",
    "zf-commons/zfc-user": "dev-master",
    "zf-commons/zfc-twig": "dev-master",
    "zf-commons/zfc-acl": "dev-master",
    "socalnick/scn-social-auth": "dev-master"
}

Should i put * instead of dev-master ?

@Ocramius
Owner

I see. Could you do fake the packages list on your side and eventually do a PR for now?
I assume changing to * would do the trick, just not sure of it. Fixing the ODM module to require0.* would also do the trick.

@jhuet

Okay, PR sent.

Please sign in to comment.
Something went wrong with that request. Please try again.