Permalink
Browse files

tweaked deps

  • Loading branch information...
1 parent 1410d30 commit 1c9594bef754c74d9bced661af9bb975c28be4b6 @lsmith77 lsmith77 committed Jan 13, 2013
Showing with 2 additions and 2 deletions.
  1. +2 −2 composer.json
View
@@ -16,11 +16,11 @@
}
],
"require": {
- "php": ">=5.3.2",
+ "php": ">=5.3.3",
"symfony/framework-bundle": ">=2.1,<2.3-dev",
"symfony/doctrine-bridge": ">=2.1,<2.3-dev",
"phpcr/phpcr-implementation": "2.1.*",
- "phpcr/phpcr-utils": ">=1.0-beta4"
+ "phpcr/phpcr-utils": "1.0-beta4"
},
"suggest": {
"doctrine/phpcr-odm": "if you want to use the odm as well. require version 1.0.*",

6 comments on commit 1c9594b

Contributor

shieldo replied Feb 17, 2013

Is there a specific reason for disallowing use of more recent beta versions of phpcr/phpcr-utils (other than just to be careful)? At time of writing, master of doctrine/phpcr-odm requires at least 1.0-beta5. You'll know better than me, but there doesn't look to be anything breaking introduced between beta4 and beta5 :)

Member

lsmith77 replied Feb 19, 2013

yes, since we have been breaking BC at times.

Member

dbu replied Feb 19, 2013

ups, here i accepted changing it to >=1.0-beta5 #35 - so this should be =1.0-beta5 ?

Member

lsmith77 replied Feb 19, 2013

well its ok if we stop breaking BC :). otherwise it can lead to broken setups

Member

stof replied Feb 19, 2013

>=1.0-beta5 is not OK as it is unbound. It should use ~1.0-beta5

Member

dbu replied Feb 24, 2013

fixed in 7531758

Please sign in to comment.