DBAL-517: [GH-317] Conditionaly upgrade utf8 to utf8mb4 for MySQL 5.5.3 #1722

Closed
doctrinebot opened this Issue May 15, 2013 · 3 comments

2 participants

@doctrinebot

Jira issue originally created by user @doctrinebot:

This issue is created automatically through a Github pull request on behalf of nicolas-grekas:

Url: #317

Message:

See http://dev.mysql.com/doc/refman/5.5/en/charset-unicode-utf8mb4.html

As utf8mb4 is a superset of utf8, this should be transparent and backward compatible.
For those really requiring the "utf8" meant by MySQL, they can use explicitely the utf8mb3 charset.
But IMHO by default, Doctrine should really use utf8mb4, which is what everybody expect from a charset named "utf8".

@doctrinebot

Comment created by @doctrinebot:

A related Github Pull-Request [GH-317] was closed:
#317

@doctrinebot

Issue was closed with resolution "Won't Fix"

@doctrinebot

Comment created by @doctrinebot:

A related Github Pull-Request [GH-317] was closed:
doctrine/common#317

@doctrinebot doctrinebot added the Bug label Dec 6, 2015
@beberlei beberlei was assigned by doctrinebot Dec 6, 2015
@doctrinebot doctrinebot closed this Dec 6, 2015
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment