Set minimum PHP version to 5.3.6 #206

Closed
wants to merge 2 commits into
from

Conversation

Projects
None yet
3 participants
@nicolas-grekas
Contributor

nicolas-grekas commented Sep 24, 2012

Since ->setCharset() has been removed, minimum PHP version has to be raised to 5.3.6: the new way of doing charset, throught the DSN, works only after bug https://bugs.php.net/bug.php?id=47802 has been fixed.

nicolas-grekas added some commits Sep 24, 2012

Set minimum PHP version to 5.3.6
The new charset option in the DSN in supported only since 5.3.6
@doctrinebot

This comment has been minimized.

Show comment Hide comment
@doctrinebot

doctrinebot Sep 24, 2012

Hello,

thank you for positing this Pull Request. I have automatically opened an issue on our Jira Bug Tracker for you with the details of this Pull-Request. See the Link:

http://doctrine-project.org/jira/browse/DBAL-351

Hello,

thank you for positing this Pull Request. I have automatically opened an issue on our Jira Bug Tracker for you with the details of this Pull-Request. See the Link:

http://doctrine-project.org/jira/browse/DBAL-351

@stof

This comment has been minimized.

Show comment Hide comment
@stof

stof Sep 25, 2012

Member

You can still use it on lower PHP versions. You simply need to use the MySQLSessionInit listener

Member

stof commented Sep 25, 2012

You can still use it on lower PHP versions. You simply need to use the MySQLSessionInit listener

@nicolas-grekas

This comment has been minimized.

Show comment Hide comment
@nicolas-grekas

nicolas-grekas Sep 25, 2012

Contributor

Then may be should UPGRADE be updated to mention that?

Contributor

nicolas-grekas commented Sep 25, 2012

Then may be should UPGRADE be updated to mention that?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment