DDC-1545: Update on loaded association not detected upon flush() #2179

Closed
doctrinebot opened this Issue Dec 18, 2011 · 8 comments

2 participants

@doctrinebot

Jira issue originally created by user bschussek:

If an association is joined during fetching and then updated in-memory, the update is not detected during flushing. I made the following test cases:

Association is joined:
** change NULL → entity: does not work*

  • change entity → NULL: works ** change entity1 → entity2: does not work*

Assocation is not joined:

  • change NULL → entity: works
  • change entity → NULL: works
  • change entity1 → entity2: works
@doctrinebot

Comment created by @guilhermeblanco:

Increasing priority

@doctrinebot

Comment created by @guilhermeblanco:

Issue fixed since this commit:

a8478d5

Thanks a lot for the bug reporting. It was the second time someone reported me this issue and I could not reproduce! =)

@doctrinebot

Issue was closed with resolution "Fixed"

@doctrinebot

Comment created by @beberlei:

This issue is referenced in Github Pull-Request GH-229
#229

@doctrinebot

Comment created by @beberlei:

Related Pull Request was closed: #229

@doctrinebot

Comment created by @beberlei:

Fixed properly now. Will be merged into 2.1.x

@doctrinebot

Comment created by @beberlei:

Update fix version, this was merged into 2.1.5

@doctrinebot doctrinebot added this to the 2.1.5 milestone Dec 6, 2015
@doctrinebot doctrinebot closed this Dec 6, 2015
@doctrinebot doctrinebot added the Bug label Dec 7, 2015
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment