DDC-2767: ID property of MayToOne association has wrong type #3513

Open
doctrinebot opened this Issue Oct 30, 2013 · 2 comments

2 participants

@doctrinebot

Jira issue originally created by user flack:

I'm seeing the following behaviour in some Doctrine code I'm writing:

$entity = array_pop($qb->getQuery()->getResult());
echo gettype($entity->getId()) . ' ' . $entity->getId();
// prints: integer 123

$association = $entity->getAssociation(); // unidirectional ManyToOne link to some other entity
echo gettype($association->getId()) . ' ' . $association->getId();
// prints: string 345

When I load the associated entity directly (via find() f.x.), it's ID has the integer type as expected, and the database structure looks correct, too.

I'm not entirely sure if this is a problem in my code or some issue in QueryBuilder or some other Doctrine component, but if someone could point me into the right direction, that would really be helpful.

I guess normally the type of the ID is not so important because you're not supposed to access it directly anyways, but I need to provide backward compatibility for a lot of code written against a different ORM API that provided exactly this behaviour.

@doctrinebot

Comment created by flack:

After some research, the problem sounds kind of similar to

http://www.doctrine-project.org/jira/browse/[DDC-2494](http://www.doctrine-project.org/jira/browse/DDC-2494)

only that in my case, it's not a custom type, but a builtin one that is not working. But AFAICT, in both cases it's getting the ID from a proxy that is problematic

@doctrinebot

Comment created by @doctrinebot:

A related Github Pull-Request [GH-1073] was closed:
#1073

@beberlei beberlei was assigned by doctrinebot Dec 6, 2015
@doctrinebot doctrinebot added the Bug label Dec 7, 2015
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment