DDC-3094: dbal and orm versions not compatible #3869

Closed
doctrinebot opened this Issue Apr 20, 2014 · 4 comments

2 participants

@doctrinebot

Jira issue originally created by user cordoval:

( ! ) Fatal error: Call to undefined method Doctrine\ORM\Event\LifecycleEventArgs::format() in /Users/cordoval/Sites/x/vendor/doctrine/dbal/lib/Doctrine/DBAL/Types/DateTimeType.php on line 53

This is happening on sf2.4 default project

"require": {
    "php": ">=5.3.3",
    "symfony/symfony": "<sub>2.4",
    "doctrine/orm": "</sub>2.2,>=2.2.3",
    "doctrine/doctrine-bundle": "<sub>1.2",
    "twig/extensions": "</sub>1.0",
    "symfony/assetic-bundle": "<sub>2.3",
    "symfony/swiftmailer-bundle": "</sub>2.3",
    "symfony/monolog-bundle": "<sub>2.4",
    "sensio/distribution-bundle": "</sub>2.3",
    "sensio/framework-extra-bundle": "<sub>3.0",
    "incenteev/composer-parameter-handler": "</sub>2.0",
    "jms/security-extra-bundle": "1.5.*",
    "jms/di-extra-bundle": "1.4.*",
    "friendsofsymfony/user-bundle": "dev-master@dev",
    "doctrine/doctrine-migrations-bundle": "dev-master@dev",
    "doctrine/migrations": "dev-master@dev",
    "doctrine/doctrine-fixtures-bundle": "dev-master@dev",
    "doctrine/data-fixtures": "dev-master@dev",
    "symfony/icu": "<sub>1.1",
    "colourstream/cron-bundle": "dev-update23@dev",
    "nelmio/alice": "dev-master@dev",
    "raulfraile/ladybug-bundle": "0.7",
    "guzzle/guzzle": "</sub>3.7",
    "jms/serializer-bundle": "0.12.0",
    "beberlei/DoctrineExtensions": "dev-master@dev"
},
"require-dev": {
    "behat/behat": "<sub>3.0@dev",
    "phpspec/phpspec": "dev-master@dev",
    "phpspec/symfony2-extension": "dev-master@dev",
    "behat/mink-bundle": "</sub>1.4",
    "phpunit/phpunit": "<sub>3.7",
    "behat/mink-selenium2-driver": "</sub>1.1"
},
@doctrinebot

Comment created by cordoval:

closing but you guys broke backward compatibility here, i had to figure it out :) thanks though

@doctrinebot

Comment created by cordoval:

:)

@doctrinebot

Issue was closed with resolution "Fixed"

@doctrinebot

Comment created by kuldipem:

I am also facing same issue with following composer.json, can you help me how to solve this issue in my application ?

"require": {
"php": ">=5.3.3",
"symfony/symfony": "2.3.",
"doctrine/orm": "2.2,>=2.2.3",
"doctrine/doctrine-bundle": "1.2.
",
"twig/extensions": "1.0.",
"symfony/assetic-bundle": "2.3.
",
"symfony/swiftmailer-bundle": "2.3.",
"symfony/monolog-bundle": "2.3.
",
"sensio/distribution-bundle": "2.3.",
"sensio/framework-extra-bundle": "2.3.
",
"sensio/generator-bundle": "2.3.*",
"incenteev/composer-parameter-handler": "2.0"
}

@beberlei beberlei was assigned by doctrinebot Dec 6, 2015
@doctrinebot doctrinebot closed this Dec 6, 2015
@doctrinebot doctrinebot added the Bug label Dec 7, 2015
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment