DDC-64: missing column type "clob" #5149

Closed
doctrinebot opened this Issue Oct 27, 2009 · 7 comments

2 participants

@doctrinebot

Jira issue originally created by user chriswest:

The legacy column type "clob" is not recognized by "Doctrine\ORM\Tools\ConvertDoctrine1Schema". It should be correctly mapped to "text".

Patch attached.

@doctrinebot

Comment created by romanb:

As you've seen, "text" is the D2 type that maps to a text/clob. This either needs to be fixed in the schema managers (Doctrine\DBAL\Schema... if they output 'clob' as a portable column type thats a bug) or in the conversion code of convert-mapping.

Where are you experiencing this? On the CLI with convert-mapping or when reverse-engineering a database?

@doctrinebot

Comment created by romanb:

To clarify: This is a real issue, just patched in the wrong location :)

@doctrinebot

Comment created by chriswest:

Yes, I experienced it when converting Doctrine 1.x YAML to 2.0. The output is still "clob" - You are right - wrong patch location then :)

@doctrinebot

Comment created by chriswest:

Attached the correct patch "legacycolumn_mappatch.patch" is the correct one. How can I delete obsolete attachments in jira?

@doctrinebot

Comment created by @jwage:

Thanks for the ticket and patch.

@doctrinebot

Issue was closed with resolution "Fixed"

@jwage jwage was assigned by doctrinebot Dec 6, 2015
@doctrinebot doctrinebot added this to the 2.0-ALPHA3 milestone Dec 6, 2015
@doctrinebot doctrinebot closed this Dec 6, 2015
@doctrinebot doctrinebot added the Bug label Dec 7, 2015
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment