Skip to content
Browse files

Merge pull request #21 from rykov/es5

Use ECMAScript 5 by default
  • Loading branch information...
2 parents c7a752c + f4436bb commit 735a2064ca7f2a191172cdf7a54f5c4922f85571 @jashkenas jashkenas committed
Showing with 5 additions and 2 deletions.
  1. +5 −2 lib/closure/compiler.rb
View
7 lib/closure/compiler.rb
@@ -9,8 +9,11 @@ class Error < StandardError; end
# The Closure::Compiler is a basic wrapper around the actual JAR. There's not
# much to see here.
class Compiler
-
- DEFAULT_OPTIONS = {:warning_level => 'QUIET'}
+
+ DEFAULT_OPTIONS = {
+ :warning_level => 'QUIET',
+ :language_in => 'ECMASCRIPT5'
+ }
# When you create a Compiler, pass in the flags and options.
def initialize(options={})

0 comments on commit 735a206

Please sign in to comment.
Something went wrong with that request. Please try again.