Skip to content

Cannot get console to work #32

Closed
roenne opened this Issue Sep 21, 2011 · 4 comments

5 participants

@roenne
roenne commented Sep 21, 2011

Hi,
I succesfully started the server and a node. But the console doesn't want to work.

/home/storm/.rvm/gems/ruby-1.8.7-p352@storming/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:466:in `load_missing_constant': uninitialized constant CloudCrowd::AssetStore (NameError)

Can anyone help out?

ER

@jashkenas
DocumentCloud member

It sounds like your configuration isn't all set up to talk to S3 correctly? Make sure that your config files are correct (see the wiki) -- and that CloudCrowd can find the config when starting up.

@jashkenas jashkenas closed this Sep 21, 2011
@eamorim
eamorim commented Oct 31, 2011

I have the same problem with the default file generate by crowd install:

:central_server: http://localhost:9173
:max_workers: 5
:storage: filesystem

I deleted the file to check if crowd was found it, and I think it is found, because the error when I remove it is:

crowd can't find the CloudCrowd configuration directory. Please use crowd -c path/to/config, or run crowd from inside of the configuration directory itself

I am not trying to use S3 in the example, so I think it is not the problem.. Someone can help me?

@coulix
coulix commented Jan 12, 2012

Same here

@vrybas vrybas added a commit to vrybas/cloud-crowd that referenced this issue Feb 12, 2012
@vrybas vrybas #32 Fix console starting up.
Everything still works without 'tmpdir' but not producing
uninitialized constant CloudCrowd::AssetStore (NameError)
ce5d695
@vrybas
vrybas commented Feb 12, 2012

Somehow works while not requiring 'tmpdir'
vrybas@ce5d695

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.