Error when running jammit 0.6.5 (ruby 1.9.3 + rails 3.2.8 + windows 7 64-bit) #240

Closed
ngrenier opened this Issue Oct 24, 2012 · 2 comments

Projects

None yet

3 participants

@ngrenier

Hi,

I try to use Jammit to build the DocumentViewer from DocumentCloud.

The first error I got when running "jammit" is:
D:/dev/apps/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load such file -- win32/open3 (LoadError)

After some research I've installed the gem win32-open3-19, which solved the first error but gives me this second error:
D:/dev/apps/Ruby193/lib/ruby/1.9.1/open3.rb:202:in `spawn': Invalid argument - java -jar D:/dev/apps/Ruby193/lib/ruby/gems/1.9.1/gems/yui-compressor-0.9.6/lib/yui/../yuicompressor-2.4.4.jar --type css --charset utf-8 (Errno::EINVAL)

Any idea about this issue and how to solve it?

Thanks!
Nicolas

@fabdouglas

Same issue there, for the same versions

@reefdog
Contributor
reefdog commented Oct 30, 2015

Closing this since so many of the components are out of date. If there are still issues with your current stack, feel free to open a new issue!

@reefdog reefdog closed this Oct 30, 2015
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment