unicode install error #6

Closed
s2zaman opened this Issue Oct 8, 2013 · 8 comments

Comments

Projects
None yet
6 participants

s2zaman commented Oct 8, 2013

I get the following error on npm install unicode
I came across with this while installing docpad-plugin-minicms and it is a dependency there.

npm http GET http://registry.npmjs.org/unicode
npm http 304 http://registry.npmjs.org/unicode

> unicode@0.4.4 postinstall d:\docmini\node_modules\unicode
> node install.js

try to read file /usr/share/unicode/UnicodeData.txt …
Warning: using slow naiv Buffer.indexOf function!
`npm install buffertools` to speed things up.
/usr/share/unicode/UnicodeData.txt not found.
try to read file /usr/share/unicode-data/UnicodeData.txt …
/usr/share/unicode-data/UnicodeData.txt not found.
try to download …
GET unicode.org:80/Public/UNIDATA/UnicodeData.txt

events.js:72
        throw er; // Unhandled 'error' event
              ^
Error: connect ETIMEDOUT
    at errnoException (net.js:901:11)
    at Object.afterConnect [as oncomplete] (net.js:892:19)
npm ERR! weird error 8
npm ERR! not ok code 0
Owner

dodo commented Oct 8, 2013

which nodejs version do you use?
can you download the txt file manually?
On 8 Oct 2013 08:11, "Shah Zaman" notifications@github.com wrote:

I get the following error on npm install unicode
I came across with this while installing docpad-plugin-minicms and it is
a dependency there.

npm http GET http://registry.npmjs.org/unicode
npm http 304 http://registry.npmjs.org/unicode

unicode@0.4.4 postinstall d:\docmini\node_modules\unicode
node install.js

try to read file /usr/share/unicode/UnicodeData.txt …
Warning: using slow naiv Buffer.indexOf function!
npm install buffertools to speed things up.
/usr/share/unicode/UnicodeData.txt not found.
try to read file /usr/share/unicode-data/UnicodeData.txt …
/usr/share/unicode-data/UnicodeData.txt not found.
try to download …
GET unicode.org:80/Public/UNIDATA/UnicodeData.txt

events.js:72
throw er; // Unhandled 'error' event
^
Error: connect ETIMEDOUT
at errnoException (net.js:901:11)
at Object.afterConnect as oncomplete
npm ERR! weird error 8
npm ERR! not ok code 0


Reply to this email directly or view it on GitHubhttps://github.com/dodo/node-unicodetable/issues/6
.

s2zaman commented Oct 8, 2013

node version: v0.10.20
NPM version: 1.3.11

I have downloaded the txt manually. I searched the README.md but couldn't configure where to set the path for it.
I also placed this file in the root directory of node-unicodetable and tried npm install but the error remains the same.

s2zaman commented Oct 9, 2013

Thanks !!
The problem is solved.
I worked out on my system and found out the following solution!!

The problem was mainly related with the docpad-plugin-minicms. So I posted the solution here.

@s2zaman s2zaman closed this Oct 9, 2013

Owner

dodo commented Oct 9, 2013

workaround != solved

Works fine for me with that node version. Looks like http.get behaves a little bit different under windows.

Anyway i made your workaround a little bit easier to install (or at least i hope i did).

@dodo dodo reopened this Oct 9, 2013

radum commented Mar 5, 2014

@s2zaman are you behind a corporate proxy or any other form of proxy server? It might be that, I've added a pull request #15 that I think fixes this issues on all platforms.

@dodo dodo closed this Mar 14, 2014

arnogues commented Jun 9, 2015

I had the same error and unicode is the only module that failed with our corporate proxy, I have tests the code of install.js and I have resolved the problem by replacing this code :

unicodedatafile = {
    host: "unicode.org",

By this code :

unicodedatafile = {
    host: "http://unicode.org",

ihr commented Apr 4, 2016

I'm running CentOS 7 and fixed the issue by doing the following:

  1. sudo yum install unicode-ucd
  2. sudo ln -s /usr/share/unicode/ucd/UnicodeData.txt /usr/share/unicode/UnicodeData.txt
  3. rm -rf node_modules/slug/ node_modules/unicode/
  4. npm install slug

this worked for me!

download UnicodeData.txt by yourself, and then put it in the directory which is the same with install.js
then run node install.js again.

@karlkfi karlkfi referenced this issue in dcos/dcos-website Mar 28, 2017

Merged

Unicode workaround #1193

1 of 3 tasks complete
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment