Permalink
Browse files

Minor changes

Light cleanup
  • Loading branch information...
1 parent ff4263e commit bb4b082c086689434d67490a15224c42fefdfd13 @leuqarte leuqarte committed with rnicoll Oct 20, 2015
Showing with 14 additions and 14 deletions.
  1. +14 −14 doc/build-unix.md
View
@@ -4,12 +4,12 @@ Some notes on how to build Dogecoin in Unix.
Note
---------------------
-Always use absolute paths to configure and compile dogecoin and the dependencies,
+Always use absolute paths to configure and compile Dogecoin and the dependencies,
for example, when specifying the the path of the dependency:
../dist/configure --enable-cxx --disable-shared --with-pic --prefix=$BDB_PREFIX
-Here BDB_PREFIX must absolute path - it is defined using $(pwd) which ensures
+Here BDB_PREFIX must be an absolute path - it is defined using $(pwd) which ensures
the usage of the absolute path.
To Build
@@ -22,7 +22,7 @@ make
make install # optional
```
-This will build dogecoin-qt as well if the dependencies are met.
+This will build Dogecoin-Qt as well if the dependencies are met.
Dependencies
---------------------
@@ -50,7 +50,7 @@ System requirements
--------------------
C++ compilers are memory-hungry. It is recommended to have at least 1 GB of
-memory available when compiling Dogecoin Core. With 512MB of memory or less
+memory available when compiling Dogecoin Core. With 512MB of memory or less,
compilation will take much longer due to swap thrashing.
Dependency Build Instructions: Ubuntu & Debian
@@ -59,7 +59,7 @@ Build requirements:
sudo apt-get install build-essential libtool autotools-dev autoconf pkg-config libssl-dev
-for Ubuntu 12.04 and later or Debian 7 and later libboost-all-dev has to be installed:
+for Ubuntu 12.04 and later or Debian 7 and later, libboost-all-dev has to be installed:
sudo apt-get install libboost-all-dev libdb5.1-dev libdb5.1++-dev
@@ -82,11 +82,11 @@ are installed. Either Qt 4 or Qt 5 are necessary to build the GUI.
If both Qt 4 and Qt 5 are installed, Qt 4 will be used. Pass `--with-gui=qt5` to configure to choose Qt5.
To build without GUI pass `--without-gui`.
-To build with Qt 4 you need the following:
+To build with Qt 4, you need the following:
sudo apt-get install libqt4-dev libprotobuf-dev protobuf-compiler
-For Qt 5 you need the following:
+For Qt 5, you need the following:
sudo apt-get install libqt5gui5 libqt5core5a libqt5dbus5 qttools5-dev qttools5-dev-tools libprotobuf-dev protobuf-compiler
@@ -164,7 +164,7 @@ If you need to build Boost yourself:
Security
--------
-To help make your dogecoin installation more secure by making certain attacks impossible to
+To help make your Dogecoin installation more secure by making certain attacks impossible to
exploit even if a vulnerability is found, binaries are hardened by default.
This can be disabled with:
@@ -195,30 +195,30 @@ Hardening enables the following features:
ET_DYN
* Non-executable Stack
- If the stack is executable then trivial stack based buffer overflow exploits are possible if
- vulnerable buffers are found. By default, dogecoin should be built with a non-executable stack
+ If the stack is executable, trivial stack-based buffer overflow exploits are possible if
+ vulnerable buffers are found. By default, Dogecoin should be built with a non-executable stack,
but if one of the libraries it uses asks for an executable stack or someone makes a mistake
and uses a compiler extension which requires an executable stack, it will silently build an
executable without the non-executable stack protection.
- To verify that the stack is non-executable after compiling use:
+ To verify that the stack is non-executable after compiling, use:
`scanelf -e ./dogecoin`
the output should contain:
STK/REL/PTL
RW- R-- RW-
- The STK RW- means that the stack is readable and writeable but not executable.
+ The STK RW- means that the stack is readable and writeable, but not executable.
Disable-wallet mode
--------------------
-When the intention is to run only a P2P node without a wallet, dogecoin may be compiled in
+When the intention is to run only a P2P node without a wallet, Dogecoin may be compiled in
disable-wallet mode with:
./configure --disable-wallet
In this case there is no dependency on Berkeley DB 4.8.
Mining is also possible in disable-wallet mode, but only using the `getblocktemplate` RPC
-call not `getwork`.
+call, not `getwork`.

0 comments on commit bb4b082

Please sign in to comment.