New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

#error "You must build your code with position independent code if Qt was built with -reduce-relocations #1422

Closed
torxie opened this Issue Jan 7, 2018 · 2 comments

Comments

Projects
None yet
3 participants
@torxie
Copy link

torxie commented Jan 7, 2018

  1. Question
    /usr/include/x86_64-linux-gnu/qt5/QtCore/qglobal.h:1067:4: error: #error "You must build your code with position independent code if Qt was built with -reduce-relocations. " "Compile your code with -fPIC (-fPIE is not enough)."

error "You must build your code with position independent code if Qt was built with -reduce-relocations. "

  1. user -fPIC
    ./configure --with-gui=qt5 --enable-upnp-default --enable-hardening LDFLAGS="-L/home/torxie/dogecoin_version_1/db5/lib/" CPPFLAGS="-fPIC -I/home/torxie/dogecoin_version_1/db5/include/"

  2. Dont work

@D3m0nKingx

This comment has been minimized.

Copy link
Contributor

D3m0nKingx commented Jan 7, 2018

https://github.com/dogecoin/dogecoin/pull/1420/files

Make the changes in the code as above, and it will compile.

@torxie

This comment has been minimized.

Copy link
Author

torxie commented Jan 8, 2018

Thank u very much~

@langerhans langerhans closed this Dec 31, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment