Permalink
Browse files

Add max_target_perl for Test::MinimumVersion control

  • Loading branch information...
1 parent a3b6756 commit fb4d430cd94fd08ab3746641d1768429f3ac31c5 @doherty committed Mar 2, 2013
Showing with 7 additions and 3 deletions.
  1. +2 −0 Changes
  2. +5 −3 lib/Dist/Zilla/PluginBundle/TestingMania.pm
View
@@ -1,6 +1,8 @@
Changelog for Dist::Zilla::PluginBundle::TestingMania
{{$NEXT}}
+ * Allow setting your maximum target perl version explicitly
+ with max_target_perl [xdg++]
0.18 2012-07-29
* Allow setting is_strict and has_version for Test::Version plugin
@@ -89,8 +89,10 @@ means.
=item *
L<Dist::Zilla::Plugin::Test::MinimumVersion>, which tests for the minimum
-required version of perl. See L<Test::MinimumVersion> for details, including
-limitations.
+required version of perl. Give the highest version of perl you intend to
+require as C<max_target_perl>. The generated test will fail if you accidentally
+used features from a version of perl newer than that. See
+L<Test::MinimumVersion> for details and limitations.
=item *
@@ -200,7 +202,7 @@ sub configure {
'Test::EOL' => 1,
'Test::Kwalitee' => 1,
MetaTests => 1, # should only be loaded if MetaYAML is loaded, or the file exists in the dist
- 'Test::MinimumVersion' => 1,
+ 'Test::MinimumVersion' => $self->config_slice('max_target_perl'),
MojibakeTests => 1,
NoTabsTests => 1,
PodCoverageTests => 1,

0 comments on commit fb4d430

Please sign in to comment.