Permalink
Browse files

Remove user-level plugin install mention from Clojure docs.

User-level plugins are not appropriate for CI situations.
  • Loading branch information...
1 parent baac9aa commit 31c0e115ab5477805e624e7c524e59460cc9a68a @technomancy technomancy committed Mar 8, 2012
Showing with 2 additions and 11 deletions.
  1. +2 −11 docs/user/languages/clojure.md
@@ -57,22 +57,13 @@ If you need to AOT compile Java sources, for example, it is possible to override
See [general build configuration guide](/docs/user/build-configuration/) to learn more.
-## Installing Leiningen Plugins
-
-If your project needs a Leiningen plugin to be installed, install it using `before_install` key. For example, to install [lein-precate](https://github.com/technomancy/lein-precate):
-
- before_install:
- - lein plugin install lein-precate 0.2.0
-
## Testing Against Multiple Versions of Clojure
-Leiningen has an excellent plugin called [lein-multi](https://github.com/maravillas/lein-multi) that lets you effortlessly test against multiple versions of Clojure (including pre-release versions like 1.4.0-beta1). Because leiningen can run tests against any version of Clojure (not necessary the one available as `clojure` in the PATH), there is no need for runtime switchers (like RVM) for Clojure.
+Leiningen has an excellent plugin called [lein-multi](https://github.com/maravillas/lein-multi) that lets you effortlessly test against multiple versions of Clojure (including pre-release versions like 1.4.0-beta1). Because leiningen can run tests against any version of Clojure (not necessary the same version as Leiningen itself uses), there is no need for runtime switchers (like RVM) for Clojure.
-To use lein-multi on travis-ci.org, first install it before dependency installation and override `script:` to run `lein multi test` instead of default `lein test`:
+To use lein-multi on travis-ci.org, add it to `:plugins` in project.clj and override `script:` to run `lein multi test` instead of default `lein test`:
language: clojure
- before_install:
- - lein plugin install lein-multi 1.1.0
script: lein multi test
For a real world example, see [Monger](https://github.com/michaelklishin/monger).

0 comments on commit 31c0e11

Please sign in to comment.