Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Shadows: Awakening black screen on startup #616

Closed
mozo78 opened this issue Sep 1, 2018 · 9 comments

Comments

Projects
None yet
5 participants
@mozo78
Copy link

commented Sep 1, 2018

The game starts and it actually doesn't freeze. The DXVK HUD shows FPS are changing but the screen is black and it ain't goes any further. I waited for 10 minutes to no avail. A tried to install DX and to disable nvapi/64 also.

Software information

Shadows: Awakening GOG

System information

  • GPU: GTX 1080Ti
  • Driver: 396.54
  • Wine version: 3.14
  • DXVK version: 0.70 / master

Apitrace file(s)

shadows.zip

Log files

@doitsujin

This comment has been minimized.

Copy link
Owner

commented Sep 1, 2018

The black screen is to be expected because the game doesn't even try to render anything. Does it work with wined3d?

@mozo78

This comment has been minimized.

Copy link
Author

commented Sep 1, 2018

Nope, here it is the wine log:
https://pastebin.com/sc8VNvWz

@doitsujin

This comment has been minimized.

Copy link
Owner

commented Sep 1, 2018

Hm. Do you have access to a Windows machine to record an apitrace on that OS? There's no indication of what might be wrong, but it's not a rendering issue because, as mentioned, the game doesn't actually render anything.

@mozo78

This comment has been minimized.

Copy link
Author

commented Sep 1, 2018

I'm very sorry but I don't use Windows.

@Tk-Glitch

This comment has been minimized.

Copy link
Contributor

commented Sep 1, 2018

Here is a windows trace of the game : https://drive.google.com/file/d/19Qnn6xt9cwujWTualVgyYOcN-IHDdMbN/view?usp=sharing
It is replaying fine though. Could be a wine issue.

@Illynir

This comment has been minimized.

Copy link

commented Sep 1, 2018

Probably the videos of logos and intro?

@mozo78

This comment has been minimized.

Copy link
Author

commented Sep 1, 2018

This is the first thing I thought of but I couldn't find anything for no intro fix on the net.

@m-svo

This comment has been minimized.

Copy link

commented Sep 14, 2018

This game needs MS Media Foundation to play intro videos. @lieff managed to play it, described here: ValveSoftware/Proton#1102 (comment)

@doitsujin

This comment has been minimized.

Copy link
Owner

commented Sep 14, 2018

Not my bug then, closing.

@doitsujin doitsujin closed this Sep 14, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.