Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Pop-in artifact in Assassin's Creed: Odyssey #928

Closed
yokem55 opened this issue Feb 20, 2019 · 15 comments

Comments

Projects
None yet
8 participants
@yokem55
Copy link

commented Feb 20, 2019

There seems to be a pop-in rendering bug in AC: Odyssey with some structures. Demonstrated in the following video:
https://youtu.be/L3CpnHNOj0Y

Software information

Assassin's Creed: Odyssey -
ACOdyssey.ini.txt

System information

  • GPU: Nvidia RTX 2080
  • Driver: 418.30.0
  • Wine version: 'tkg-protonified-4.1', esync enabled.
  • DXVK version: 0.96

Apitrace file(s)

  • Unable to create demonstrating the issue. The game crashes while the save game is loading with the API trace active. (enabled by placing the DLL's along the game's executable). I'm happy to try a different method to get the trace if one is known for this game.

Log files

@doitsujin doitsujin added the nvidia label Feb 20, 2019

@doitsujin

This comment has been minimized.

Copy link
Owner

commented Feb 20, 2019

Can't reproduce, everything renders fine on RADV. Can you please test whether this happens with the latest Nvidia Vulkan beta driver as well?

@ah-

This comment has been minimized.

Copy link
Contributor

commented Feb 20, 2019

I've tried to reproduce this on Proton 3.16-7 and 418.31.03 on both max and medium settings but couldn't spot anything like it. Maybe this got fixed?

@yokem55

This comment has been minimized.

Copy link
Author

commented Feb 21, 2019

I can confirm this is indeed fixed with the 418.31.03 drivers. Thank you.

@yokem55 yokem55 closed this Feb 21, 2019

@yaffa7

This comment has been minimized.

Copy link

commented Mar 16, 2019

This game has been working flawlessly for the past couple months. But a an upgrade to Nvidia drivers 4.18.43 and Vulkan 1.1.95 has immediately caused the issue described here to start happening.

  • GPU: Nvidia RTX 1080
  • Driver: 418.43.0
  • Wine version: 'tkg-4.2'
  • DXVK version: 1.0

Video: https://youtu.be/EBJYPTtGwWg

Will provide logs as soon as i can

@doitsujin Should i start a new issue for this or continue this thread?

@doitsujin

This comment has been minimized.

Copy link
Owner

commented Mar 16, 2019

@yaffa7 this is not a DXVK bug and it is my understanding that this issue is fixed in the Nvidia beta drivers. Please use that for now.

@yokem55

This comment has been minimized.

Copy link
Author

commented Mar 18, 2019

This issue has returned again in the latest nvidia vulkan beta (418.49.04). Reverting to the previous vulkan beta (418.31.03) fixes it. Not sure what we can tell nvidia, but whatever they did in 418.31.03 did not get passed on in future versions.

@tsalwierz

This comment has been minimized.

Copy link

commented Mar 18, 2019

Confirmed, bug is on 418.49.04.

@yokem55

This comment has been minimized.

Copy link
Author

commented Apr 7, 2019

Back on 481.49.04 to run DXVK 1.1, it appears to be that this bug is now resolved.

Edit. Actually not. Still present.

@yokem55

This comment has been minimized.

Copy link
Author

commented Apr 16, 2019

@doitsujin doitsujin reopened this Apr 22, 2019

@Vash63

This comment has been minimized.

Copy link

commented Apr 22, 2019

20190422234133_1

Screenshot of the issue with the latest Vulkan dev drivers (418.52.05)

@Vash63

This comment has been minimized.

Copy link

commented Apr 23, 2019

Not sure if this is expected based on branch dates or something but I can also duplicate this on 430.09

@chaitan3

This comment has been minimized.

Copy link

commented May 20, 2019

Duplicated on 430.14. Downgrading the nvidia driver to 415.27 fixes the issue.

@Vash63

This comment has been minimized.

Copy link

commented May 23, 2019

I can duplicate this on yesterday's new 418.52.07 drivers as well.

@Vash63

This comment has been minimized.

Copy link

commented Jun 3, 2019

I can no longer duplicate this with 418.52.10! Seems they fixed it.

@chui2ch

This comment has been minimized.

Copy link

commented Jun 12, 2019

It seems to be fixed in the new 430.26 driver as well as the beta.

@doitsujin doitsujin closed this Jun 12, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.