Skip to content
Browse files

Scope::Guard is now a requirement for 5.10 as well as 5.8

  • Loading branch information...
1 parent 515fc23 commit c6a566bcebf3ecc934db4ff21b455a20093ee57f @pjf pjf committed Jun 29, 2008
Showing with 7 additions and 5 deletions.
  1. +6 −4 Changes
  2. +1 −1 Makefile.PL
View
10 Changes
@@ -2,9 +2,9 @@ Revision history for Fatal
1.10_07 Sun Jun 29 15:54:26 AUSEST 2008
* RELEASE CODENAME: "ikegami", in thanks for solving the problem
- of getting lexical replacement of subroutines working for real
- under Perl 5.8. As this works better than my 5.10 implemenation,
- it forms the foundation for this release.
+ of getting lexical replacement of subroutines working for real
+ under Perl 5.8. As this works better than my 5.10 implemenation,
+ it forms the foundation for this release.
* Removed inappropriate diagnostics about :lexical from Fatal.pm
@@ -36,7 +36,9 @@ Revision history for Fatal
* Expanded documentation on autodie, particularly for
exception handling under Perl 5.8.
- * Less warnings from t/exceptions.t when running under 5.10.
+ * Less warnings from t/exceptions.t when running under 5.10.
+
+ * All releases now really depend upon Scope::Guard, not just 5.8.
1.10_06 Sun Jun 22 21:50:39 AUSEST 2008
View
2 Makefile.PL
@@ -9,7 +9,7 @@ version_from( 'lib/autodie/exception.pm');
test_requires( 'Test::More');
requires( 'perl' => '5.8.0');
-requires( 'Scope::Guard' => 0) if $] < 5.010; # For 5.8 support.
+requires( 'Scope::Guard' => 0);
recommends( 'IPC::System::Simple' => '0.12'); # For autodying system()

0 comments on commit c6a566b

Please sign in to comment.
Something went wrong with that request. Please try again.