Skip to content
Permalink
Browse files

Merge pull request #8324 from CookiePLMonster/adapter-combo-fix

Enable adapter combo only if adapters are supported by current backend
  • Loading branch information...
JosJuice committed Sep 28, 2019
2 parents de700eb + df0ff7f commit 06ab51bceb878422746d33d2f9d005f9ba665099
Showing with 2 additions and 1 deletion.
  1. +2 −1 Source/Core/DolphinQt/Config/Graphics/GeneralWidget.cpp
@@ -187,7 +187,8 @@ void GeneralWidget::OnEmulationStateChanged(bool running)
m_backend_combo->setEnabled(!running);
m_render_main_window->setEnabled(!running);

m_adapter_combo->setEnabled(!running);
const bool supports_adapters = !g_Config.backend_info.Adapters.empty();
m_adapter_combo->setEnabled(!running && supports_adapters);
}

void GeneralWidget::AddDescriptions()

0 comments on commit 06ab51b

Please sign in to comment.
You can’t perform that action at this time.