Permalink
Browse files

CMake: Increase minimum GCC version to 6.0

Dolphin uses nested namespaces from the C++17 standard,
which are only supported in GCC 6.0 and later.

See comments in GH-6866 for details.
  • Loading branch information...
akien-mga committed May 30, 2018
1 parent 1825e23 commit c36695175f4faf13dd0cfecde1092ee4c979999f
Showing with 2 additions and 2 deletions.
  1. +2 −2 CMakeLists.txt
View
@@ -203,8 +203,8 @@ endif()
# Enforce minimum GCC version
if(CMAKE_CXX_COMPILER_ID STREQUAL "GNU" AND CMAKE_CXX_COMPILER_VERSION VERSION_LESS 5.0)
message(FATAL_ERROR "Dolphin requires at least GCC 5.0 (found ${CMAKE_CXX_COMPILER_VERSION})")
if(CMAKE_CXX_COMPILER_ID STREQUAL "GNU" AND CMAKE_CXX_COMPILER_VERSION VERSION_LESS 6.0)
message(FATAL_ERROR "Dolphin requires at least GCC 6.0 (found ${CMAKE_CXX_COMPILER_VERSION})")
endif()
if(CMAKE_GENERATOR MATCHES "Ninja")

0 comments on commit c366951

Please sign in to comment.