Skip to content
Permalink
Browse files

Bump minimum GCC version to 7.0

GCC 7.0 is the first version with full support for C++17.
Also fixes some bugs like https://stackoverflow.com/questions/32097759
  • Loading branch information...
leoetlino committed Dec 25, 2017
1 parent 04c8201 commit c40ae4508dcf6a14ad7a810fe8cd83488aa59103
Showing with 2 additions and 2 deletions.
  1. +2 −2 CMakeLists.txt
@@ -203,8 +203,8 @@ endif()


# Enforce minimum GCC version
if(CMAKE_CXX_COMPILER_ID STREQUAL "GNU" AND CMAKE_CXX_COMPILER_VERSION VERSION_LESS 6.0)
message(FATAL_ERROR "Dolphin requires at least GCC 6.0 (found ${CMAKE_CXX_COMPILER_VERSION})")
if(CMAKE_CXX_COMPILER_ID STREQUAL "GNU" AND CMAKE_CXX_COMPILER_VERSION VERSION_LESS 7.0)
message(FATAL_ERROR "Dolphin requires at least GCC 7.0 (found ${CMAKE_CXX_COMPILER_VERSION})")
endif()

if(CMAKE_GENERATOR MATCHES "Ninja")

0 comments on commit c40ae45

Please sign in to comment.
You can’t perform that action at this time.