Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

DolphinQt: Fix qt.qpa.plugin on MacOS #8435

Open
wants to merge 1 commit into
base: master
from

Conversation

@firodj
Copy link

firodj commented Oct 27, 2019

Got error after successful build using CMake on Mac OSX High Sierra. Qt5 was installed using Qt Online Installer for macOS.

The error message when running Dolphin:

qt.qpa.plugin: Could not load the Qt platform plugin "cocoa" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: cocoa.
After inspecting with otool the problem was the @rpath or
LC_RPATH which not set on the Dolphin executable (target dolphin-emu) which needed by libqcocoa.dylib.

@leoetlino leoetlino requested a review from spycrab Nov 9, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
1 participant
You can’t perform that action at this time.