New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

OTGW: PS=0 after PS=1 #634

Closed
zuidwijk opened this Issue May 1, 2016 · 2 comments

Comments

Projects
None yet
2 participants
@zuidwijk

zuidwijk commented May 1, 2016

Is it possible to not use PS=1 in Domoticz? Or send a PS=0 after sending PS=1?

void OTGWBase::GetGatewayDetails()
{
char szCmd[30];
strcpy(szCmd, "PR=G\r\n");
WriteInt((const unsigned char_)&szCmd, (const unsigned char)strlen(szCmd));
strcpy(szCmd, "PR=I\r\n");
WriteInt((const unsigned char_)&szCmd, (const unsigned char)strlen(szCmd));
strcpy(szCmd, "PR=O\r\n");
WriteInt((const unsigned char_)&szCmd, (const unsigned char)strlen(szCmd));
strcpy(szCmd, "PS=1\r\n");
WriteInt((const unsigned char_)&szCmd, (const unsigned char)strlen(szCmd));
strcpy(szCmd, "PS=0\r\n");
WriteInt((const unsigned char)&szCmd, (const unsigned char)strlen(szCmd));*
}

I'm running Domoticz on a Rpi 3 and using it to control my lights and thermostat vi homebridge (working perfect). Yet I want to gather more information on what my boiler is doing. Therefore I like to use Grafana
Grafana is collecting information from otmonitor. Otmonitor stops working/collecting data when Domoticz send the PS=1 command.

I've tried manually to add a PS=0 after each PS=1 command and that is working.

Please let me know if this is possible, I'd like to have more insight information.

@gizmocuz

This comment has been minimized.

Contributor

gizmocuz commented May 1, 2016

Don't cross post... (both forum and github, also plz use github for developer issues)
You can use MQTT to grafana if you want to

@gizmocuz gizmocuz closed this May 1, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment