Permalink
Browse files

Add support for Rails 5.1 and drop support for Ruby 2.1 since it is EOL

Prepare new release
  • Loading branch information...
donv committed Jul 9, 2017
1 parent 5ed78b6 commit 6a5c535aee7bd6a608d3cf4fdca2fe803bd3db52
Showing with 6 additions and 6 deletions.
  1. +1 −1 .rubocop.yml
  2. +2 −4 .travis.yml
  3. +2 −0 gemfiles/rails_5.1.gemfile
  4. +1 −1 lib/simple_workflow/version.rb
View
@@ -1,7 +1,7 @@
inherit_from: .rubocop_todo.yml
AllCops:
TargetRubyVersion: 2.1
TargetRubyVersion: 2.2
DisplayCopNames: true
DisplayStyleGuide: true
Include:
View
@@ -3,9 +3,8 @@ sudo: false
rvm:
- 2.4.1
- 2.3.4
- jruby-9.1.8.0
- jruby-9.1.12.0
- 2.2.7
- 2.1.9
- jruby-head
jdk:
@@ -19,13 +18,12 @@ before_install:
- bundle install
gemfile:
- gemfiles/rails_5.1.gemfile
- gemfiles/rails_5.0.gemfile
- gemfiles/rails_4.2.gemfile
matrix:
exclude:
- rvm: 2.1.9
gemfile: gemfiles/rails_5.0.gemfile
allow_failures:
- rvm: jruby-head
gemfile: gemfiles/rails_5.0.gemfile # Low coverage
@@ -0,0 +1,2 @@
eval File.read(File.expand_path('common.gemfile', __dir__)), binding
gem 'rails', '~>5.1.2'
@@ -1,3 +1,3 @@
module SimpleWorkflow
VERSION = '1.3.4'.freeze
VERSION = '1.3.5'.freeze
end

0 comments on commit 6a5c535

Please sign in to comment.