Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

"content" key in Key/Value Field is not displayed in content edit window #16046

Closed
dsolistorres opened this issue Feb 14, 2019 · 3 comments

Comments

@dsolistorres
Copy link
Contributor

commented Feb 14, 2019

Reported via support ticket: 97528
Reproducible in dotCMS 4.3.3, 5.0.3

When an entry is added for Key/Value field using the word "content" for the key, and the contentlet is saved, the next time the content is edited the entry doesn't display in the content edit window.

Expected Behavior

All Key/Value field entries should display when the content is edited. If the "content" key is used for a new entry for a Key/Value fields, and the contentlet is saved and the edit window is closed, the next time that the content is edited the entry should display.

Current Behavior

If the "content" word is used for a new entry in a Key/Value field, and the contentlet is saved, the next time that the content is edited (after close the content edit window and open it again), the entry doesn't display.

Possible Solution

The code that displays the Key/Value field entries, has a condition to skip the entry is the key is equals to "content" word:

if(key.equals("content")){
continue;
}

That condition can be removed so the entry displays in the content edit window.

Known Workarounds

There's no known workarounds for this issue.

Steps to Reproduce

  1. Log into dotCMS 5.0.3
  2. Add a Key/Value field for a content type.
  3. Edit a content item for the the content type from the previous step. Add a new entry to the Key/Value field using the word "content" as the key.
  4. Save the content item and close the content edition window.

content-key

  1. Edit the content item again.
  2. The entry with the "content" key doesn't display

key-doesnt-show

Context

This was reported by client in this support issue: 97528

Your Environment

  • dotCMS version used: 4.3.3, 5.0.3
  • Browser Name and version: Not relevant
  • Operating System and version: Not relevant
  • Application Server and version: Not relevant
  • Java Brand and version: Not relevant
  • Database and version: Not relevant
  • Application module (if apply): Content management
@dsolistorres

This comment has been minimized.

Copy link
Contributor Author

commented Feb 27, 2019

Attached hotfix for 4.3.3
hotfix-GIT-16046_v4.3.3.zip

dsolistorres added a commit that referenced this issue Mar 8, 2019

@dsolistorres

This comment has been minimized.

Copy link
Contributor Author

commented Mar 8, 2019

PR: #16190

dsilvam added a commit that referenced this issue Apr 10, 2019

@bryanboza bryanboza added this to CODY in QA Apr 10, 2019

@bryanboza

This comment has been minimized.

Copy link
Contributor

commented Apr 10, 2019

Fixed, tested on master // Postgres // FF. Unable to reproduce after the last changes

@bryanboza bryanboza moved this from CODY to Done in QA Apr 10, 2019

@jtesser jtesser moved this from Important Issues to Fixed in a Newer Release in Enterprise Services Issues May 1, 2019

@wezell wezell closed this May 7, 2019

Enterprise Services Issues automation moved this from Fixed in a Newer Release to Done May 7, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.