Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Key/value fields are not added to the index #16313

Closed
dsolistorres opened this issue Mar 29, 2019 · 9 comments

Comments

@dsolistorres
Copy link
Contributor

commented Mar 29, 2019

Reproducible in dotCMS 5.1.1

Key/value fields are not added to the index when they are saved as user searchable.

To Reproduce
Steps to reproduce the behavior:

  1. Log into dotCMS 5.1.1
  2. Add a Key/Value field for a content type.
  3. Save the field as "User searchable".
  4. Add values for the Key/Value fields for a content item and save the content item.
  5. Do a search from the Content Search portlet or from the Query Tool, using the value added in the previous step for the Key/Value field.
  6. The content item is not returned from the search.

Expected behavior
The Key/Value field should be added to the index when it's saved as "User searchable", and Content Search should return results when content is searched using the Key/Value field.

Screenshots
Added "user searchable" key/value field to the content type:
key-value-field

Saved and published a key/value for a content item:
key-value-field-saved

Search by key/value doesn't return results:
search-results

@brentgriffin

This comment has been minimized.

Copy link
Contributor

commented Jun 4, 2019

Still a problem in 5.1.5

@wezell wezell added this to the Rex Current milestone Jun 4, 2019

@bryanboza bryanboza added this to To do in Release 5.1.6 Jun 4, 2019

dsilvam added a commit that referenced this issue Jun 4, 2019

dsilvam added a commit that referenced this issue Jun 4, 2019

@dsilvam

This comment has been minimized.

Copy link
Contributor

commented Jun 4, 2019

PR: #16675

dsilvam added a commit that referenced this issue Jun 4, 2019

@erickgonzalez

This comment has been minimized.

Copy link
Contributor

commented Jun 4, 2019

Working as it should in the release branch.

@bryanboza bryanboza added this to CODY in QA Jun 5, 2019

@bryanboza bryanboza moved this from To do to Needs QA in Release 5.1.6 Jun 5, 2019

@bryanboza

This comment has been minimized.

Copy link
Contributor

commented Jun 5, 2019

Tested in the last release branch and we continue with problems using this kind of fields
SC: https://screencast.com/t/ZpFxPlrCt4Q

@bryanboza bryanboza moved this from Needs QA to To do in Release 5.1.6 Jun 5, 2019

@erickgonzalez

This comment has been minimized.

Copy link
Contributor

commented Jun 5, 2019

@bryanboza you need to search it like this test:1 or key1:v, like the example @dsolistorres posted above.

@bryanboza

This comment has been minimized.

Copy link
Contributor

commented Jun 6, 2019

After making some tests, we detect the problem is the license if you don't have a license, we are unable to search content by this field. After apply a license I'm unable to reproduce the problem

@bryanboza

This comment has been minimized.

Copy link
Contributor

commented Jun 6, 2019

Fixed, now when you have a license we are adding those fields to the index. New related cards here #16690 & #16691

@bryanboza bryanboza moved this from To do to Done in Release 5.1.6 Jun 6, 2019

@jcastro-dotcms

This comment has been minimized.

Copy link
Contributor

commented Jun 6, 2019

Regarding Bryan's comment:

After making some tests, we detect the problem is the license if you don't have a license, we are unable to search content by this field. After apply a license I'm unable to reproduce the problem

Is this stated in our official documentation?

@dsilvam dsilvam modified the milestones: 060419_REX, Rex Current Jun 7, 2019

@bryanboza

This comment has been minimized.

Copy link
Contributor

commented Jun 10, 2019

Fixed, new the detected problems should be fixed in the new cards

@bryanboza bryanboza added Passed QA and removed Needs QA labels Jun 10, 2019

@bryanboza bryanboza moved this from CODY to Done in QA Jun 10, 2019

@wezell wezell closed this Jun 11, 2019

Enterprise Services Issues automation moved this from Important Issues to Done Jun 11, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.