New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Unable to install on VS Professional 2013 (12.0.40629.0 update 5) #237

Closed
MithunChopda opened this Issue Jul 26, 2016 · 3 comments

Comments

Projects
None yet
2 participants
@MithunChopda

With lot of excitement I fired the first command Install-Package BenchmarkDotNet and boom.

I got the following error.

PM> Install-Package BenchmarkDotNet
Attempting to resolve dependency 'Microsoft.CodeAnalysis.CSharp (≥ 1.3.2)'.
Attempting to resolve dependency 'Microsoft.CodeAnalysis.Common (= 1.3.2)'.
Attempting to resolve dependency 'System.Collections.Immutable (≥ 1.1.37)'.
Attempting to resolve dependency 'System.Reflection.Metadata (≥ 1.2.0)'.
Install-Package : 'System.Reflection.Metadata' already has a dependency defined for 'System.Collections.Immutable'.
At line:1 char:16

  • Install-Package <<<< BenchmarkDotNet
    • CategoryInfo : NotSpecified: (:) [Install-Package], InvalidOperationException
    • FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand

What must me wrong?

@adamsitnik

This comment has been minimized.

Show comment
Hide comment
@adamsitnik

adamsitnik Jul 27, 2016

Member

@MithunChopda Thans for the bug report! I was able to reproduce it, it's proably Roslyn fault. I have reported it in Roslyn's repo

What I can offer you right now is to use our 0.9.7 version (we did not use Roslyn then)

Member

adamsitnik commented Jul 27, 2016

@MithunChopda Thans for the bug report! I was able to reproduce it, it's proably Roslyn fault. I have reported it in Roslyn's repo

What I can offer you right now is to use our 0.9.7 version (we did not use Roslyn then)

@adamsitnik adamsitnik self-assigned this Jul 27, 2016

@adamsitnik adamsitnik added the bug label Jul 27, 2016

@MithunChopda

This comment has been minimized.

Show comment
Hide comment
@MithunChopda

MithunChopda Jul 27, 2016

I am able to install 0.9.7. Thank you.

I am able to install 0.9.7. Thank you.

@adamsitnik

This comment has been minimized.

Show comment
Hide comment
@adamsitnik

adamsitnik Sep 6, 2016

Member

"you will need to use Visual Studio 2015 for that package."

The issue got rejected by Microsoft, which means that we can not support VS 2013 now. I don't like it, but I will close this one as well.

Member

adamsitnik commented Sep 6, 2016

"you will need to use Visual Studio 2015 for that package."

The issue got rejected by Microsoft, which means that we can not support VS 2013 now. I don't like it, but I will close this one as well.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment