Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Update compat pack to depend on WCF latest stable version and give ability to depend on external non-stable packages #42464

Merged
merged 2 commits into from Nov 9, 2019

Conversation

@safern
Copy link
Member

safern commented Nov 8, 2019

…bility to depend on external non-stable packages
@safern safern force-pushed the safern:DependOnWcfStableVersion branch from fe9ae45 to 5567085 Nov 8, 2019
@ericstj

This comment has been minimized.

Copy link
Member

ericstj commented Nov 8, 2019

Can you diff NuSpecs before and after this change to confirm that it only changes what you want?

@ericstj
ericstj approved these changes Nov 8, 2019
@safern

This comment has been minimized.

Copy link
Member Author

safern commented Nov 8, 2019

Can you diff NuSpecs before and after this change to confirm that it only changes what you want?

Sure.

@safern

This comment has been minimized.

Copy link
Member Author

safern commented Nov 8, 2019

Ok, so after my last commit I diff the .nuspec files and the only difference is in Microsoft.Windows.Compatibility as expected, bumping the wcf dependencies to 4.7.0:

image

image

@danmosemsft danmosemsft changed the title Update compat pack to depend on WCF latest stable version and give hability to depend on external non-stable packages Update compat pack to depend on WCF latest stable version and give ability to depend on external non-stable packages Nov 8, 2019
@ericstj
ericstj approved these changes Nov 8, 2019
@safern

This comment has been minimized.

Copy link
Member Author

safern commented Nov 9, 2019

/azp run corefx-ci

@azure-pipelines

This comment has been minimized.

Copy link

azure-pipelines bot commented Nov 9, 2019

Azure Pipelines successfully started running 1 pipeline(s).
@safern safern merged commit b7e6f39 into dotnet:master Nov 9, 2019
15 checks passed
15 checks passed
WIP Ready for review
Details
corefx-ci Build #20191108.49 succeeded
Details
corefx-ci (Linux Build RedHat6_x64_Release) Linux Build RedHat6_x64_Release succeeded
Details
corefx-ci (Linux Build arm64_Debug) Linux Build arm64_Debug succeeded
Details
corefx-ci (Linux Build arm_Debug) Linux Build arm_Debug succeeded
Details
corefx-ci (Linux Build musl_arm64_Debug) Linux Build musl_arm64_Debug succeeded
Details
corefx-ci (Linux Build musl_x64_Debug) Linux Build musl_x64_Debug succeeded
Details
corefx-ci (Linux Build wasm_Release) Linux Build wasm_Release succeeded
Details
corefx-ci (Linux Build x64_Debug) Linux Build x64_Debug succeeded
Details
corefx-ci (MacOS Build x64_Debug) MacOS Build x64_Debug succeeded
Details
corefx-ci (Windows Build NETFX_x86_Release) Windows Build NETFX_x86_Release succeeded
Details
corefx-ci (Windows Build x64_Debug) Windows Build x64_Debug succeeded
Details
corefx-ci (Windows Build x86_Release) Windows Build x86_Release succeeded
Details
corefx-ci (Windows Packaging All Configurations x64_Debug) Windows Packaging All Configurations x64_Debug succeeded
Details
license/cla All CLA requirements met.
Details
@safern safern deleted the safern:DependOnWcfStableVersion branch Nov 9, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.