New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Todo list via navigation tree gives not found error (Origin: bugzilla #607432) #3638

Closed
doxygen opened this Issue Jul 2, 2018 · 0 comments

Comments

Projects
None yet
1 participant
@doxygen
Owner

doxygen commented Jul 2, 2018

status RESOLVED severity normal in component doxywizard for ---
Reported in version 1.6.2 on platform Other
Assigned to: Dimitri van Heesch

Original attachment names and IDs:

On 2010-01-19 10:33:35 +0000, AJ Visser wrote:

On Windows (XP SP3), I had installed doxygen 1.6.1.
I just added a few todo in my source code (C++) and after recreating the HTML output, I saw a Todo List in the navigation tree. I use the Output option HTML only with frames and a nagivation tree. It works.

Than I installed doxygen 1.6.2 right on top of 1.6.1. Made a few adjustments to my code and let doxywizard regenerate the HTML docs. It works as normal, except the Todo list via the navigation tree gives an 'Not found' error in my browser (Chrome 3.0).

If I navigate to one of the function, which contains a @todo and from there I try to access the Todo List, it works.

To see whether the upgrade from 1.6.1 to 1.6.2 was the problem, I removed the complete HTML tree and let doxywizard generate the HTML output. Still no luck.
Even in different browsers (Firefox 3.5.7) and IE8, the Todo List is not available.

The whole doxyfile project, contains currently about 8 cpp files (7 class implementation, 1 main file) and a diversity of header files (classes and abstract classes)

On 2010-01-19 11:45:20 +0000, Dimitri van Heesch wrote:

Do you have SHORT_NAMES enabled? If so then please retry with this option disabled, let me know if that makes a difference. If you already had it disabled, then please attach a self-contained example (source+config file) that allows me to reproduce the problem.

On 2010-01-19 12:14:21 +0000, AJ Visser wrote:

SHORT_NAMES has not effect, whether it is enabled or disabled. It had been disabled though.

I have attached a zip file, which contains a few code classes I am using. This is the minimal set, I was able to reproduce this error.
It also contains the doxyfile. All have been testen in C:\SeaConf.

The function SerialDevice::Create contains the @todo note.

Hopefully this is enough for you.

On 2010-01-19 12:16:27 +0000, AJ Visser wrote:

Created attachment 151754
Contains doxyfile and code to reproduce above error

This zip file, contains a doxyfile and sourcecode to reproduce the bug that has been described here.

On 2010-01-21 09:14:38 +0000, AJ Visser wrote:

According to Chrome: This is the link that is used from the navigation tree:
file:///.../html/dd/da0/todo.html (Note the dd/da0)

Using the Todo links in functions, the link is:
file:///.../html/todo.html (Is correct).

The dd/da0 is first link, may be different is attached example. This is because this comes from the complete html generated by the project doxyfile instead of test doxyfile.

On 2010-01-21 11:08:11 +0000, Jan Humpl wrote:

I found, that this issue also causes that eclipse search does not work (GENERATE_ECLIPSE_HELP feature). This is because eclipse stop searching when it founds non-valid link. If I manualy correct links in toc.xml then eclipse search works OK.

On 2010-01-23 11:53:16 +0000, Dimitri van Heesch wrote:

Confirmed. So it seems that setting CREATE_SUBDIRS to YES can also cause this issue. Should be fixed in the next subversion update.

On 2010-01-30 10:42:04 +0000, Dimitri van Heesch wrote:

*** Bug 608002 has been marked as a duplicate of this bug. ***

On 2010-02-08 19:02:57 +0000, Poul-Erik Hansen wrote:

(In reply to comment # 1)

Do you have SHORT_NAMES enabled? If so then please retry with this option
disabled, let me know if that makes a difference. If you already had it
disabled, then please attach a self-contained example (source+config file) that
allows me to reproduce the problem.

I have the same error, but the bug decipher when "SHORT_NAME" is disabled.

On 2010-02-21 12:57:32 +0000, Dimitri van Heesch wrote:

This bug was previously marked ASSIGNED, which means it should be fixed in
doxygen version 1.6.3. Please verify if this is indeed the case. Reopen the
bug if you think it is not fixed and please include any additional information
that you think can be relevant.

@doxygen doxygen closed this Jul 2, 2018

@doxygen doxygen added the doxywizard label Jul 19, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment