New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Anchors missing for QHP documented members (Origin: bugzilla #623673) #3837

Closed
doxygen opened this Issue Jul 2, 2018 · 0 comments

Comments

Projects
None yet
1 participant
@doxygen
Owner

doxygen commented Jul 2, 2018

status RESOLVED severity normal in component general for ---
Reported in version 1.7.1 on platform Other
Assigned to: Dimitri van Heesch

Original attachment names and IDs:

On 2010-07-06 12:11:21 +0000, Simon wrote:

The index file (*.qhp) for the Qt help documentation generator does not have any of the anchor hashes for e.g. class members.

If I look up a class member in the Qt assistant application, it takes me to the correct class page, but not to the specific anchor.

On 2010-07-06 12:13:49 +0000, Simon wrote:

Created attachment 165352
Patch to fix missing anchors

I've attached a patch which calls MemberDef::anchor() during QHP generation. Seems that addIndexItem is no longer passed the anchor as parameter.

On 2010-07-06 18:38:04 +0000, Dimitri van Heesch wrote:

Confirmed. I'll include your patch in the next subversion update.

On 2010-10-09 08:19:21 +0000, Dimitri van Heesch wrote:

This bug was previously marked ASSIGNED, which means it should be fixed in
doxygen version 1.7.2. Please verify if this is indeed the case. Reopen the
bug if you think it is not fixed and please include any additional information
that you think can be relevant.

@doxygen doxygen closed this Jul 2, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment