New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Latex $projectname with "&" gets no escaped (Origin: bugzilla #626172) #3893

Closed
doxygen opened this Issue Jul 2, 2018 · 0 comments

Comments

Projects
None yet
1 participant
@doxygen
Owner

doxygen commented Jul 2, 2018

status RESOLVED severity major in component build for ---
Reported in version 1.7.1 on platform Other
Assigned to: Dimitri van Heesch

On 2010-08-06 09:32:45 +0000, Axel Heider wrote:

doxyfile sets
PROJECT_NAME = "Foo&Bar Project"
LATEX_HEADER = "mySpecialheader.tex"

mySpecialheader.tex uses "$projectname" somewhere. Latex complains "! Misplaced alignment tab character &.", because the "&" from the project name, does nor get translated to "&".

On 2010-08-09 09:02:34 +0000, Axel Heider wrote:

using "\verb+$projectname+" is a work around. But it does no look very nice when the typewriter font is used.

On 2010-08-11 12:30:47 +0000, Anne wrote:

Axel, have you tried writing PROJECT_NAME = "Foo&Bar Project"?
Within XML comments, that works for me. I've never had to name a project with an ampersand though.

On 2010-08-11 12:40:46 +0000, Axel Heider wrote:

I gave it a try, but it does no work. And "&" is just valid XML, but no valid latex code. So if doxygen does not detect and replace it, it wont work.
The Error is again:

! Misplaced alignment tab character &.
l.81 Foo&
amp;Bar Project }\
! ==> Fatal error occurred, no output PDF file produced!

It apears that doxygen has to apply some translation on the internal variables for latex output. Maybe for RTF and other targets as well.

On 2010-10-28 18:33:22 +0000, Gary wrote:

I get something similar in 1.7.2: However, dealing with the following doxygen generated Latex output:

\begin{DoxyParams}{Parameters}
{\em param1} & description1 \
\hline
{\em param2} & description2 \
\hline
\end{DoxyParams}

The error generated is the same:
Doxygen/latex/group__FILE.tex:46: Misplaced alignment tab character &.

On 2010-10-28 20:23:54 +0000, Gary wrote:

(In reply to comment # 4)

I get something similar in 1.7.2: However, dealing with the following doxygen
generated Latex output:

\begin{DoxyParams}{Parameters}
{\em param1} & description1 \
\hline
{\em param2} & description2 \
\hline
\end{DoxyParams}

The error generated is the same:
Doxygen/latex/group__FILE.tex:46: Misplaced alignment tab character &.

Opened up a different bug report for this issue in particular:

633397

On 2014-01-04 14:42:59 +0000, albert wrote:

Ive just pushed a solution to github (pull request 79)

On 2014-01-05 18:09:05 +0000, Dimitri van Heesch wrote:

Thanks, I've merged the pull request.

On 2014-04-21 10:09:22 +0000, Dimitri van Heesch wrote:

This bug was previously marked ASSIGNED, which means it should be fixed in
doxygen version 1.8.7. Please verify if this is indeed the case. Reopen the
bug if you think it is not fixed and please include any additional information
that you think can be relevant (preferrably in the form of a self-contained example).

@doxygen doxygen closed this Jul 2, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment