New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Broken PROJECT_LOGO in HTML or CHM (Origin: bugzilla #657704) #4385

Closed
doxygen opened this Issue Jul 2, 2018 · 0 comments

Comments

Projects
None yet
1 participant
@doxygen
Owner

doxygen commented Jul 2, 2018

status RESOLVED severity minor in component general for ---
Reported in version 1.7.5.1 on platform Other
Assigned to: Dimitri van Heesch

Original attachment names and IDs:

On 2011-08-30 13:38:23 +0000, tdf.webmaster@gmail.com wrote:

Created attachment 195197
Screenshot of broken project logo from CHM output

Hello,

I generate CHM documentation. In the Doxyfile, the value of PROJECT_LOGO $(COMRES_DIR)\logo.bmp. The variable exists, and the path it points to exists as well.

Regardless if I hardcode the path (D:\Projects\Common Resources\logo.bmp) or if it partially contains a environment variable, the bitmap is broken in the HTML and CHM output of the documentation.

In the CHM output, a "missing bitmap" icon is used in place of the bitmap.
In the HTML out, the text "Logo" is used in place of the bitmap.

I have attached screenshots of results from the HTML and CHM outputs.

Since the path to the bitmap contains a space, I have also tried the following variations:

"$(COMRES_DIR)\logo.bmp"
"D:\Projects\Common Resources\logo.bmp"

but to no avail.

I have previously used version 1.7.4 and this was not an issue.

On 2011-08-30 13:38:50 +0000, tdf.webmaster@gmail.com wrote:

Created attachment 195198
Screenshot of broken project logo from HTML output

On 2013-02-10 19:18:15 +0000, albert wrote:

Created attachment 235635
PATCH: check not only for / but also for \

In stripPath not only strip paths with / but also with .

Note" could not test on a Linux system, so I don't know what will happen when the logo name contains a space and this has been escaped by means of a \ or a path that contains for the same reasons a /

On 2013-03-31 10:20:04 +0000, Dimitri van Heesch wrote:

Thanks, I'll include the patch in the next subversion update.

On 2013-05-19 12:36:19 +0000, Dimitri van Heesch wrote:

This bug was previously marked ASSIGNED, which means it should be fixed in
doxygen version 1.8.4. Please verify if this is indeed the case. Reopen the
bug if you think it is not fixed and please include any additional information
that you think can be relevant.

@doxygen doxygen closed this Jul 2, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment