New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Uses <img> instead of <object> html tag for SVG images (Origin: bugzilla #675165) #4691

Closed
doxygen opened this Issue Jul 2, 2018 · 0 comments

Comments

Projects
None yet
1 participant
@doxygen
Owner

doxygen commented Jul 2, 2018

status RESOLVED severity minor in component build for ---
Reported in version 1.8.0 on platform Other
Assigned to: Dimitri van Heesch

On 2012-04-30 16:04:50 +0000, strange-corner wrote:

When embedding an image into html documentation with the \image tag, images of all formats will be embedded with the tag. For SVG, would be fine.

On 2012-04-30 17:07:39 +0000, Dimitri van Heesch wrote:

I don't understand your problem/proposal.

Doxygen uses <iframe> for SVGs, not or .
The reason not to use is that this format does not support embedded javascript inside the SVG, which I use when INTERACTIVE_SVG is enabled.

What is the reason for wanting (if that is what you are asking for)?

On 2012-05-01 05:58:25 +0000, strange-corner wrote:

No, that't not what I'm asking for.

For example:
\image html image.svg

results in;
image.svg

Doxygen DOES use the tag in the html output. There is no <iframe> tag and no tag. I think, an tag would be correct.

On 2012-09-19 10:21:21 +0000, Roberto wrote:

I am agree whit strange-corner. If image.svg contain linked raster graphic, I can't see raster graphic in doxygen output html page since it use tag.

A fast solution is to add an alias like this:

"imagesvg{1} = \n \htmlonly

<object type="image/svg+xml" data="\1" alt="\1" >

\endhtmlonly \n "

Would be fine if:

\image html image.png
\image html image.svg

results in;
image.png

On 2016-05-15 12:28:52 +0000, Dimitri van Heesch wrote:

Confirmed. Should be fixed in the next GIT update.

On 2016-09-05 13:46:25 +0000, Dimitri van Heesch wrote:

This bug was previously marked ASSIGNED, which means it should be fixed in
doxygen version 1.8.12. Please verify if this is indeed the case. Reopen the
bug if you think it is not fixed and please include any additional information
that you think can be relevant (preferably in the form of a self-contained example).

@doxygen doxygen closed this Jul 2, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment