New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Tree View doesn't display on IE7 (Origin: bugzilla #678102) #4751

Closed
doxygen opened this Issue Jul 2, 2018 · 0 comments

Comments

Projects
None yet
1 participant
@doxygen
Owner

doxygen commented Jul 2, 2018

status RESOLVED severity normal in component general for ---
Reported in version 1.8.1.1 on platform Other
Assigned to: Dimitri van Heesch

Original attachment names and IDs:

On 2012-06-14 14:14:54 +0000, Bryan Kitts wrote:

Tree view doesn't display at all in IE7 (sadly standard browser at work)

Seems due to trailing comma in object literal in navtreeindexNN.js files, meaning the script doesn't load. If I manually delete it from one of them, that script loads and the tree is displayed.

On 2012-06-14 18:19:26 +0000, Dimitri van Heesch wrote:

Since I have no IE7 installed anywhere anymore, can you attach an output file with and without the manual edit (or a diff of both), so I know exactly what to change?

On 2012-06-15 08:29:30 +0000, Bryan Kitts wrote:

Created attachment 216495
Original output

On 2012-06-15 08:33:49 +0000, Bryan Kitts wrote:

Created attachment 216496
Patched version

The change is the last character on the penultimate line.

Original:

var NAVTREEINDEX42 =
{
"group__Sandbox.html#gaeea2c0ba997e7ed1c57fad013783da46":[8,1,0,99],
...
"nr3_8h.html#abb324d10407ebaabd5e0b393245c7f5b":[11,0,5,241,37],
"nr3_8h.html#abbefda5aee8e26da41ae345b190cc557":[11,0,5,241,50],
};

Works on IE7:

var NAVTREEINDEX42 =
{
"group__Sandbox.html#gaeea2c0ba997e7ed1c57fad013783da46":[8,1,0,99],
...
"nr3_8h.html#abb324d10407ebaabd5e0b393245c7f5b":[11,0,5,241,37],
"nr3_8h.html#abbefda5aee8e26da41ae345b190cc557":[11,0,5,241,50]
};

On 2012-06-16 15:23:38 +0000, Dimitri van Heesch wrote:

Confirmed. Should be fixed in the next subversion update.

On 2012-07-12 15:42:02 +0000, Dimitri van Heesch wrote:

This bug was previously marked ASSIGNED, which means it should be fixed in
doxygen version 1.8.1.2. Please verify if this is indeed the case. Reopen the
bug if you think it is not fixed and please include any additional information
that you think can be relevant.

On 2012-07-13 07:59:17 +0000, Bryan Kitts wrote:

Confirmed fixed in 1.8.1.2. Thanks very much!

@doxygen doxygen closed this Jul 2, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment