New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

SHORT_NAMES break references to \page in PDF output (Origin: bugzilla #688858) #4963

Closed
doxygen opened this Issue Jul 2, 2018 · 0 comments

Comments

Projects
None yet
1 participant
@doxygen
Owner

doxygen commented Jul 2, 2018

status VERIFIED severity normal in component general for ---
Reported in version 1.8.2 on platform Other
Assigned to: Dimitri van Heesch

Original attachment names and IDs:

On 2012-11-22 09:13:44 +0000, Brice Goglin wrote:

Hello,

doxygen generates broken references to pages in the PDF output of the hwloc project documentation. This seems to be related to SHORT_NAMES=yes.
The HTML output is fine.

I am attaching a small testcase. Just unpack, enter the directory, and run
$ doxygen doxygen.cfg
$ cd doc/latex
$ pdflatex refman.tex

If you open doc/html/index.html, you'll see that all links in "Introduction" work. If you open doc/latex/refman.pdf, you'll see that the link to the section work while the page link points to PDF first page.

I get in the pdflatex output:
pdfTeX warning (dest): name{a00001} has been referenced but
does not exist, replaced by a fixed one

While debugging, I found out that the bug disappears when SHORT_NAMES=no.

This bug exists with 1.8.2 but I verified in our old releases' documentation, it has existed for at least 18 months (1.7.4).

thanks
Brice

On 2012-11-26 16:21:01 +0000, Simon A Watts wrote:

I'd like to confirm that we also experienced this with the version of Doxygen current as of April 2011. I certainly saw the '{a00001}' links in latex output which caused the visible problem.

This affected the subpage links in PDF output - meaning that we could only ship the (unaffected) HTML documentation for that project.

We were unable to isolate the issue at the time.

On 2013-03-06 14:27:56 +0000, Brice Goglin wrote:

Any chance somebody fixes this bug?
thanks
Brice

On 2013-07-20 07:01:44 +0000, Brice Goglin wrote:

Created attachment 249677
testcase to reproduce the problem

Forgot to attach it earlier

On 2013-07-20 07:04:58 +0000, Brice Goglin wrote:

Created attachment 249678
fixed the testcase

On 2013-08-04 09:58:36 +0000, Dimitri van Heesch wrote:

Confirmed. Should be fixed in the next GIT update.

On 2013-08-04 21:09:51 +0000, Brice Goglin wrote:

Yeah latest GIT looks OK, thanks! Let's hope my other bug report # 688861 will get fixed soon as well :)

On 2013-08-23 15:04:19 +0000, Dimitri van Heesch wrote:

This bug was previously marked ASSIGNED, which means it should be fixed in
doxygen version 1.8.5. Please verify if this is indeed the case. Reopen the
bug if you think it is not fixed and please include any additional information
that you think can be relevant.

On 2013-11-11 14:41:17 +0000, Brice Goglin wrote:

Sorry for the delay, I was hoping there would be a fix for # 688861 before testing all what I need, and forgot completely.

688858 is indeed fixed in 1.8.5.

Thanks.

@doxygen doxygen closed this Jul 19, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment