Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Misleading warning about DOT font (Origin: bugzilla #703301) #5228

Closed
doxygen opened this Issue Jul 2, 2018 · 0 comments

Comments

Projects
None yet
1 participant
@doxygen
Copy link
Owner

doxygen commented Jul 2, 2018

status RESOLVED severity normal in component documentation for ---
Reported in version 1.8.4 on platform Other
Assigned to: Dimitri van Heesch

On 2013-06-29 07:40:48 +0000, Stefan wrote:

Hi Dimitri,

I just upgraded from 1.8.3.1 to 1.8.4 and got the following message:

Warning: doxygen no longer ships with the FreeSans font.
You may want to clear or change DOT_FONTPATH.
Otherwise you run the risk that the wrong font is being used for dot generated graphs.
<<

The DOT_FONTPATH variable was empty, so the real cause for this warning was that DOT_FONTNAME was still set to FreeSans.

I would change the sentence "You may want to clear or change DOT_FONTPATH." to "You may want to clear or change DOT_FONTNAME.", which was what I had to do to get rid of the warning.

Thanks in advance.


Stefan

On 2013-06-30 10:01:23 +0000, Dimitri van Heesch wrote:

Confirmed. Should be fixed in the next GIT update.

On 2013-08-23 15:04:47 +0000, Dimitri van Heesch wrote:

This bug was previously marked ASSIGNED, which means it should be fixed in
doxygen version 1.8.5. Please verify if this is indeed the case. Reopen the
bug if you think it is not fixed and please include any additional information
that you think can be relevant.

@doxygen doxygen closed this Jul 2, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.