New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Can't build with MinGW (Origin: bugzilla #704971) #5246

Closed
doxygen opened this Issue Jul 2, 2018 · 0 comments

Comments

Projects
None yet
1 participant
@doxygen
Owner

doxygen commented Jul 2, 2018

status RESOLVED severity major in component build for ---
Reported in version 1.8.4-GIT on platform Other
Assigned to: Dimitri van Heesch

Original attachment names and IDs:

On 2013-07-27 08:35:14 +0000, Suzumizaki-Kimitaka wrote:

Created attachment 250255
add compiler/linker options, auto detection, activate including stdint.h, etc.

Neither doxygen.exe nor doxywizard.exe can be built in the MinGW environment.

Since I made the patch, please apply this.

On 2013-07-28 13:12:17 +0000, Suzumizaki-Kimitaka wrote:

Oops, I forgot to tell one problem remains.

While building doxywizard.exe, 'rm config_lex.cpp' fails.

I can just place dummy 'addon/doxywizard/config_lex.cpp' or
replace:
flex -Pconfig config.l
rm config_lex.cpp
mv lex.config.c config_lex.cpp
with:
flex -Pconfig -oconfig_lex.cpp config.l

in the files addon/doxywizard/Makefile.doxywizard.Release(Debug).

But the files Makefile...Release(Debug) are automatically generated and
I don't know how to fix to make the patch.

Cheers,
Suzumizaki-Kimitaka

On 2013-07-28 13:44:17 +0000, Dimitri van Heesch wrote:

Thanks, I'll include the patch in the next GIT update.

Regarding the issue in comment 1: I assume rm fails because it is not installed? The rm/mv calls are generated by qmake. So this should be fixed by providing the proper qmake.conf file for MinGW that defines QMAKE_COPY & QMAKE_MOVE.

On 2013-08-01 12:15:03 +0000, Suzumizaki-Kimitaka wrote:

Regarding the issue in comment 1: I assume rm fails because it is not
installed? The rm/mv calls are generated by qmake. So this should be fixed by
providing the proper qmake.conf file for MinGW that defines QMAKE_COPY &
QMAKE_MOVE.

The 'rm' command seems correctly installed and be working, otherwise why I CAN 'make clean' or 'rm --help' ? ;D

Okay, I have to learn about qmake...

Regards,
Suzumizaki-Kimitaka

On 2013-08-23 15:04:33 +0000, Dimitri van Heesch wrote:

This bug was previously marked ASSIGNED, which means it should be fixed in
doxygen version 1.8.5. Please verify if this is indeed the case. Reopen the
bug if you think it is not fixed and please include any additional information
that you think can be relevant.

@doxygen doxygen closed this Jul 2, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment