New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

\cite confused by labels ending with a dot (Origin: bugzilla #741778) #5694

Closed
doxygen opened this Issue Jul 2, 2018 · 0 comments

Comments

Projects
None yet
1 participant
@doxygen
Owner

doxygen commented Jul 2, 2018

status RESOLVED severity normal in component general for ---
Reported in version 1.8.8 on platform Other
Assigned to: Dimitri van Heesch

On 2014-12-19 18:44:37 +0000, marc.glisse@inria.fr wrote:

$ cat biblio.bib
@misc{ploum,author="Me",title="Whatever"}
$ cat x.h
/** \brief My class
*

  • This is documented in \cite ploum.
    */
    struct A {};

With doxygen-1.8.7, this was working fine. With 1.8.8, I get:
/tmp/dox/x.h:1: warning: unable to resolve reference to `ploum.' for \cite command

and the generated page indeed does not link to the bibliography.

On 2014-12-22 11:30:46 +0000, Dimitri van Heesch wrote:

I could 'solve' the problem with the latest snapshot from GitHub by adding

CITE_BIB_FILES = biblio.bib

to the config file. I'm sure you already did this.

Version 1.8.8 still shows the problem, so there was a problem with that release.

I'll use this report to further improve the warning in case CITE_BIB_FILES is empty.

On 2014-12-25 16:02:30 +0000, Dimitri van Heesch wrote:

This bug was previously marked ASSIGNED, which means it should be fixed in
doxygen version 1.8.9. Please verify if this is indeed the case. Reopen the
bug if you think it is not fixed and please include any additional information
that you think can be relevant (preferrably in the form of a self-contained example).

@doxygen doxygen closed this Jul 2, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment