New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Figure title needs to be on separate line in order for it to work (Origin: bugzilla #760086) #5923

Closed
doxygen opened this Issue Jul 2, 2018 · 0 comments

Comments

Projects
None yet
1 participant
@doxygen
Owner

doxygen commented Jul 2, 2018

status RESOLVED severity normal in component documentation for ---
Reported in version 1.8.11 on platform Other
Assigned to: Dimitri van Heesch

On 2016-01-02 23:11:19 +0000, Alin wrote:

In order for me to get a figure title to display in RTF, I have to do this:

//!
//! \image rtf "Interrupt Manager Layers.emf"
//! Figure: Interrupt Manager Layers
//!

which is contrary to what the manual says and the example provided. Also note that I do not have quotes around the title because if I include them, the quotes show up in the final product document.

The manual (1.8.11) says for \image:

The third argument is optional and can be used to specify the caption that is displayed below the image. This argument has to be specified on a single line and between quotes even if it does not contain any spaces. The quotes are stripped before the caption is displayed.

and the example in the manual is this:

Here is example of a comment block:
/*! Here is a snapshot of my new application:

  • \image html application.jpg
  • \image latex application.eps "My application" width=10cm
    */

On 2016-01-03 19:09:15 +0000, albert wrote:

Currently the caption is not supported by the rtf version of the \image command. The line that you inserted as "Figure: Interrupt Manager Layers" is just the next line in the text.

Currently I'm working on an implementation, but there are some more commands than only \image to be taken into consideration.

On 2016-01-06 14:53:10 +0000, albert wrote:

If just pushed a proposed patch to github (pull request 438)

The proposed patch also contains an update for the other image formats used by doxygen.

On 2016-01-07 18:49:43 +0000, Dimitri van Heesch wrote:

Thanks, I've merged the pull request

On 2016-09-05 13:45:24 +0000, Dimitri van Heesch wrote:

This bug was previously marked ASSIGNED, which means it should be fixed in
doxygen version 1.8.12. Please verify if this is indeed the case. Reopen the
bug if you think it is not fixed and please include any additional information
that you think can be relevant (preferably in the form of a self-contained example).

@doxygen doxygen closed this Jul 2, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment