Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

ncurses library for lua

branch: master

Fetching latest commit…

Octocat-spinner-32-eaf2f5

Cannot retrieve the latest commit at this time

Octocat-spinner-32 src
Octocat-spinner-32 test
Octocat-spinner-32 LICENSE
Octocat-spinner-32 Make.config
Octocat-spinner-32 Make.linux
Octocat-spinner-32 Make.osx
Octocat-spinner-32 Makefile
Octocat-spinner-32 README
Octocat-spinner-32 TODO
README
LuaNcurses v0.02
Jesse Luehrs (jluehrs2@uiuc.edu)

OVERVIEW
========
LuaNcurses is a wrapper around the ncurses library for terminal programming. It aims to expose the ncurses library in a way that is more natural to Lua programmers, rather than just be a thin wrapper around C function calls. It is currently rather incomplete, but most basic functionality is available.

INSTALL
=======
This module requires Lua 5.1 and the ncurses library. To install, modify the Make.config file with paths appropriate to your system and run 'make' and 'make install'.

DOCUMENTATION
=============
None yet, but hopefully the included tests should be explanatory enough for now. Real docs should be available in a later release.

CHANGES
=======
0.02
- Lots of cleanups
- Portability fixes - should build properly on OS X now, among other things

0.01
- Initial basic implementation

COPYRIGHT AND LICENSE
=====================
Copyright (C) 2008 Jesse Luehrs

This code is distributed under the MIT license; a copy is in the LICENSE file distributed with the source.
Something went wrong with that request. Please try again.