Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse code

s/MacFUSE/OSXFUSE/g;

Instead of recommending the use of MacFUSE, suggest the newer, actually
maintained OSXFUSE. Keeping the MacFUSE compat hack for now, since it
doesn't impact OSXFUSE (and I just tested it on a Mac OS 10.6 system
in front of me; "make test" goes off with zero hitches).
  • Loading branch information...
commit 5db105210ac5acbc268736362148359c9cc8158c 1 parent 27cfb2d
Derrik Pates authored March 14, 2012

Showing 1 changed file with 3 additions and 2 deletions. Show diff stats Hide diff stats

  1. 5  Makefile.PL
5  Makefile.PL
@@ -55,7 +55,7 @@ unless ($fusever) {
55 55
         $explanation = 'Could not find librefuse? Maybe install "perfuse" from pkgsrc, or upgrade to newer NetBSD';
56 56
     }
57 57
     elsif ($^O eq 'darwin') {
58  
-        $explanation = 'Please install MacFuse from http://code.google.com/p/macfuse/';
  58
+        $explanation = 'Please install OSXFUSE from http://osxfuse.github.com/';
59 59
     }
60 60
     else {
61 61
         $explanation = 'There is no FUSE support for your platform to our knowledge, sorry';
@@ -73,7 +73,8 @@ chomp(my $libs = `pkg-config --libs-only-L fuse 2> /dev/null`);
73 73
 chomp($libs .= `pkg-config --libs-only-l fuse 2> /dev/null` || (($^O eq 'netbsd') ? '-lrefuse' : '-lfuse'));
74 74
 # Needed for Fuse on OS X 10.6, due to 10.6 and up always using the 64-bit
75 75
 # inode structs; unfortunately MacFuse doesn't just do the right thing
76  
-# on its own.
  76
+# on its own. (Not applicable for OSXFUSE; it uses a new SONAME, so we
  77
+# don't have to worry about conflicts/compatibility, it "just works".)
77 78
 if ($^O eq 'darwin' && (uname())[2] =~ /^1[01]\./) {
78 79
     $libs =~ s/-lfuse/-lfuse_ino64/;
79 80
 }

0 notes on commit 5db1052

Please sign in to comment.
Something went wrong with that request. Please try again.