Skip to content

Loading…

SBT error in Chat example #15

Closed
ViliusN opened this Issue · 2 comments

2 participants

@ViliusN

When I try to run sbt update ~jetty-run, I get the following error. My guess is that it has something to do with SBT version (mine is 0.13.1).

$ sbt update ~jetty-run
Loading /usr/share/java/sbt/bin/sbt-launch-lib.bash
scala.MatchError: 0.13.1 (of class java.lang.String)
at $e7f9728439bdab55777c$$anonfun$$sbtdef$1.apply(/home/vilius/Desktop/simply_lift-master/chat/project/plugins.sbt:1)
at $e7f9728439bdab55777c$$anonfun$$sbtdef$1.apply(/home/vilius/Desktop/simply_lift-master/chat/project/plugins.sbt:1)
at scala.Function1$$anonfun$compose$1.apply(Function1.scala:47)
at sbt.EvaluateSettings$MixedNode.evaluate0(INode.scala:175)
at sbt.EvaluateSettings$INode.evaluate(INode.scala:134)
at sbt.EvaluateSettings$$anonfun$sbt$EvaluateSettings$$submitEvaluate$1.apply$mcV$sp(INode.scala:66)
at sbt.EvaluateSettings.sbt$EvaluateSettings$$run0(INode.scala:75)
at sbt.EvaluateSettings$$anon$3.run(INode.scala:71)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:744)
[error] scala.MatchError: 0.13.1 (of class java.lang.String)
[error] Use 'last' for the full log.
Project loading failed: (r)etry, (q)uit, (l)ast, or (i)gnore?

@ViliusN

Ah, ok. I was supposed to run the included sbt, not my local. Now it's ok.
Maybe the tutorial section 2.6 "Running it" could say "[..] type ./sbt update ~jetty-run" instead of "[..] type sbt update ~jetty-run".

@dpp
Owner
dpp commented

If there are any issues with Simply Lift, please discuss them on the Lift mailing list. Please do not open tickets.

@dpp dpp closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.