Upgrade from 3.1.0RC2 > 3.6 Issues #111

Closed
Kalaratri opened this Issue Apr 21, 2017 · 4 comments

Comments

Projects
None yet
1 participant
@Kalaratri

Kalaratri commented Apr 21, 2017

Starting with this post here I set out to upgrade my version to 3.6, but couldn't get the upgrade to run.

http://discuss.dradisframework.org/t/upgrading-dradis-ce-3-1-0rc2-to-latest-via-git-pull/449

I am a little confused. Up until now I have been running bundle exec rails server from the /usr/lib/dradis folder and using Dradis-CE 3.10RC2 through a project Maybe this was a mistake? Should I have been running this from opt/dradis-ce? I am in the middle of a project, but have taken a VMware snapshot prior so I can revert to a working state when possible.

Attached are my notes from the upgrade attempt. For now I'll roll back my snapshot and carry on working using 3.1.0RC2 from /usr/lib/dradis directory, but I'd love to see the new capabilities, so hoping we can resolve this with my extensive notes:

Many thanks

dradis 3.6 upgrade notes.txt

@Kalaratri

This comment has been minimized.

Show comment
Hide comment
@Kalaratri

Kalaratri Apr 21, 2017

PS some details about my environment:

ruby -v
ruby 2.3.1p112 (2016-04-26) [i386-linux-gnu]

uname -a
Linux kali 4.6.0-kali1-686 #1 SMP Debian 4.6.4-1kali1 (2016-07-21) i686 GNU/Linux

I also have rvm installed:

cat /usr/local/rvm/VERSION
1.29.1

However I am not sure if this is configured correctly.

PS some details about my environment:

ruby -v
ruby 2.3.1p112 (2016-04-26) [i386-linux-gnu]

uname -a
Linux kali 4.6.0-kali1-686 #1 SMP Debian 4.6.4-1kali1 (2016-07-21) i686 GNU/Linux

I also have rvm installed:

cat /usr/local/rvm/VERSION
1.29.1

However I am not sure if this is configured correctly.

@Kalaratri

This comment has been minimized.

Show comment
Hide comment
@Kalaratri

Kalaratri Apr 21, 2017

Perhaps this is related?

https://www.bountysource.com/issues/44076108-gem-load-error-is-uninitialized-constant-timeout-error

Tried:

root@kali:/opt/dradis-ce# gem uninstall bundler
Successfully uninstalled bundler-1.14.5
root@kali:/opt/dradis-ce# gem install bundler --version '1.14.4'
Fetching: bundler-1.14.4.gem (100%)
Did you know that maintaining and improving Bundler and RubyGems.org costs more than $25,000 USD every month? Help us keep the gem ecosystem free for everyone by joining the hundreds of companies and individuals who help cover these costs: https://ruby.to/support-bundler
Successfully installed bundler-1.14.4
Parsing documentation for bundler-1.14.4
Installing ri documentation for bundler-1.14.4
Done installing documentation for bundler after 7 seconds
1 gem installed
root@kali:/opt/dradis-ce# bundler check
Warning: the running version of Bundler (1.14.4) is older than the version that created the lockfile (1.14.5). We suggest you upgrade to the latest version of Bundler by running gem install bundler.
The Gemfile's dependencies are satisfied
root@kali:/opt/dradis-ce# bundle exec rails server

But had the same error

/var/lib/gems/2.3.0/gems/bundler-1.14.4/lib/bundler/runtime.rb:94:in `rescue in block (2 levels) in require': There was an error while trying to load the gem 'uglifier'. (Bundler::GemRequireError)
Gem Load Error is: wrong argument type Class (expected Module)

Kalaratri commented Apr 21, 2017

Perhaps this is related?

https://www.bountysource.com/issues/44076108-gem-load-error-is-uninitialized-constant-timeout-error

Tried:

root@kali:/opt/dradis-ce# gem uninstall bundler
Successfully uninstalled bundler-1.14.5
root@kali:/opt/dradis-ce# gem install bundler --version '1.14.4'
Fetching: bundler-1.14.4.gem (100%)
Did you know that maintaining and improving Bundler and RubyGems.org costs more than $25,000 USD every month? Help us keep the gem ecosystem free for everyone by joining the hundreds of companies and individuals who help cover these costs: https://ruby.to/support-bundler
Successfully installed bundler-1.14.4
Parsing documentation for bundler-1.14.4
Installing ri documentation for bundler-1.14.4
Done installing documentation for bundler after 7 seconds
1 gem installed
root@kali:/opt/dradis-ce# bundler check
Warning: the running version of Bundler (1.14.4) is older than the version that created the lockfile (1.14.5). We suggest you upgrade to the latest version of Bundler by running gem install bundler.
The Gemfile's dependencies are satisfied
root@kali:/opt/dradis-ce# bundle exec rails server

But had the same error

/var/lib/gems/2.3.0/gems/bundler-1.14.4/lib/bundler/runtime.rb:94:in `rescue in block (2 levels) in require': There was an error while trying to load the gem 'uglifier'. (Bundler::GemRequireError)
Gem Load Error is: wrong argument type Class (expected Module)

@Kalaratri

This comment has been minimized.

Show comment
Hide comment
@Kalaratri

Kalaratri Apr 21, 2017

bundler check
The Gemfile's dependencies are satisfied
root@kali:/opt/dradis-ce# bundler outdated
Fetching https://github.com/dradis/dradis-plugins.git
Fetching https://github.com/dradis/dradis-projects.git
Fetching gem metadata from https://rubygems.org/..........
Fetching version metadata from https://rubygems.org/..
Fetching dependency metadata from https://rubygems.org/.
Resolving dependencies......

Outdated gems included in the bundle:

  • RedCloth (newest 4.3.2, installed 4.3.1, requested = 4.3.1) in groups "default"
  • arel (newest 8.0.0, installed 7.1.4)
  • bcrypt (newest 3.1.11, installed 3.1.10, requested = 3.1.10) in groups "default"
  • blankslate (newest 3.1.3, installed 2.1.2.4)
  • bootstrap-sass (newest 3.3.7, installed 2.3.2.2, requested ~> 2.3.2.2) in groups "default"
  • dradis-html_export (newest 3.6.0, installed 3.3.3, requested = 3.3.3) in groups "default"
  • image_size (newest 1.5.0, installed 1.3.1, requested ~> 1.3.0) in groups "default"
  • jquery-fileupload-rails (newest 0.4.7, installed 0.3.5, requested ~> 0.3.4) in groups "default"
  • json (newest 2.1.0, installed 1.8.2, requested = 1.8.2) in groups "default"
  • kaminari (newest 1.0.1, installed 0.16.3, requested ~> 0.16.1) in groups "default"
  • libv8 (newest 5.3.332.38.5, installed 3.16.14.19)
  • listen (newest 3.1.5, installed 3.0.8, requested <= 3.1.1, ~> 3.0.5) in groups "development"
  • mustermann (newest 1.0.0, installed 1.0.0.beta2)
  • mysql2 (newest 0.4.5, installed 0.3.18, requested = 0.3.18) in groups "default"
  • paper_trail (newest 7.0.1, installed 4.0.2, requested ~> 4.0.0) in groups "default"
  • parslet (newest 1.8.0, installed 1.4.0, requested ~> 1.4.0) in groups "default"
  • rack-protection (newest 2.0.0.rc2, installed 2.0.0.beta2)
  • sinatra (newest 2.0.0.rc2, installed 2.0.0.beta2, requested = 2.0.0.beta2) in groups "default"
  • slop (newest 4.4.1, installed 3.6.0)
  • uglifier (newest 3.2.0, installed 3.0.4) in groups "default"
  • unicorn (newest 5.3.0, installed 4.9.0, requested = 4.9.0) in groups "production"
    root@kali:/opt/dradis-ce#

bundler check
The Gemfile's dependencies are satisfied
root@kali:/opt/dradis-ce# bundler outdated
Fetching https://github.com/dradis/dradis-plugins.git
Fetching https://github.com/dradis/dradis-projects.git
Fetching gem metadata from https://rubygems.org/..........
Fetching version metadata from https://rubygems.org/..
Fetching dependency metadata from https://rubygems.org/.
Resolving dependencies......

Outdated gems included in the bundle:

  • RedCloth (newest 4.3.2, installed 4.3.1, requested = 4.3.1) in groups "default"
  • arel (newest 8.0.0, installed 7.1.4)
  • bcrypt (newest 3.1.11, installed 3.1.10, requested = 3.1.10) in groups "default"
  • blankslate (newest 3.1.3, installed 2.1.2.4)
  • bootstrap-sass (newest 3.3.7, installed 2.3.2.2, requested ~> 2.3.2.2) in groups "default"
  • dradis-html_export (newest 3.6.0, installed 3.3.3, requested = 3.3.3) in groups "default"
  • image_size (newest 1.5.0, installed 1.3.1, requested ~> 1.3.0) in groups "default"
  • jquery-fileupload-rails (newest 0.4.7, installed 0.3.5, requested ~> 0.3.4) in groups "default"
  • json (newest 2.1.0, installed 1.8.2, requested = 1.8.2) in groups "default"
  • kaminari (newest 1.0.1, installed 0.16.3, requested ~> 0.16.1) in groups "default"
  • libv8 (newest 5.3.332.38.5, installed 3.16.14.19)
  • listen (newest 3.1.5, installed 3.0.8, requested <= 3.1.1, ~> 3.0.5) in groups "development"
  • mustermann (newest 1.0.0, installed 1.0.0.beta2)
  • mysql2 (newest 0.4.5, installed 0.3.18, requested = 0.3.18) in groups "default"
  • paper_trail (newest 7.0.1, installed 4.0.2, requested ~> 4.0.0) in groups "default"
  • parslet (newest 1.8.0, installed 1.4.0, requested ~> 1.4.0) in groups "default"
  • rack-protection (newest 2.0.0.rc2, installed 2.0.0.beta2)
  • sinatra (newest 2.0.0.rc2, installed 2.0.0.beta2, requested = 2.0.0.beta2) in groups "default"
  • slop (newest 4.4.1, installed 3.6.0)
  • uglifier (newest 3.2.0, installed 3.0.4) in groups "default"
  • unicorn (newest 5.3.0, installed 4.9.0, requested = 4.9.0) in groups "production"
    root@kali:/opt/dradis-ce#
@Kalaratri

This comment has been minimized.

Show comment
Hide comment
@Kalaratri

Kalaratri Apr 22, 2017

dradis 3.6 upgrade notes.txt

Success! I managed to troubleshoot through enough to get Dradis-CE 3.6 working. Here's my detailed notes in case it helps others. Note I still am having trouble importing data from 3.1.0RC2, but will create a separate ticket for that. Upgrade notes attached, maybe it will help others through the troubleshooting process.

Kalaratri commented Apr 22, 2017

dradis 3.6 upgrade notes.txt

Success! I managed to troubleshoot through enough to get Dradis-CE 3.6 working. Here's my detailed notes in case it helps others. Note I still am having trouble importing data from 3.1.0RC2, but will create a separate ticket for that. Upgrade notes attached, maybe it will help others through the troubleshooting process.

@Kalaratri Kalaratri closed this Apr 22, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment