Permalink
Browse files

Pre-emptively deal with require issues.

Basically, when anyone else made a 'resource_override' generator,
it'd only require once. Because that's how require works. So let's make
sure that we require ours and nobody else's.

See rails-api/active_model_serializers@2edaa22
  • Loading branch information...
1 parent c0837b3 commit f9ef1f3a92f25d31a6a976ee42d72dd94d80b89d @steveklabnik steveklabnik committed Apr 4, 2013
Showing with 1 addition and 1 deletion.
  1. +1 −1 lib/draper/railtie.rb
View
@@ -6,7 +6,7 @@ class Railtie < Rails::Railtie
app ||= Rails.application # Rails 3.0.x does not yield `app`
Rails::Generators.configure! app.config.generators
- require 'generators/resource_override'
+ require_relative 'generators/resource_override'
end
end
end

0 comments on commit f9ef1f3

Please sign in to comment.