Investigate why Travis is broken? #392

Closed
steveklabnik opened this Issue Dec 18, 2012 · 9 comments

Comments

Projects
None yet
3 participants
Owner

steveklabnik commented Dec 18, 2012

I get all passing locally, but Travis says we're failing: https://travis-ci.org/drapergem/draper/builds/3717738 and a rebuild https://travis-ci.org/drapergem/draper/builds/3717738

:'(

Do the tests run for you, @nashby @haines ?

Member

nashby commented Dec 18, 2012

It fails for me as on Travis :(

Steve Klabnik wrote:

I get all passing locally, but Travis says we're failing:
https://travis-ci.org/drapergem/draper/builds/3717738 and a rebuild
https://travis-ci.org/drapergem/draper/builds/3717738

:'(

Do the tests run for you, @nashby https://github.com/nashby @haines
https://github.com/haines ?


Reply to this email directly or view it on GitHub
#392.

Member

nashby commented Dec 18, 2012

looks like because of this
steveklabnik/request_store@7b2d9c2

Steve Klabnik wrote:

I get all passing locally, but Travis says we're failing:
https://travis-ci.org/drapergem/draper/builds/3717738 and a rebuild
https://travis-ci.org/drapergem/draper/builds/3717738

:'(

Do the tests run for you, @nashby https://github.com/nashby @haines
https://github.com/haines ?


Reply to this email directly or view it on GitHub
#392.

Member

nashby commented Dec 18, 2012

yeah, it works with 1.0.0 version

Steve Klabnik wrote:

I get all passing locally, but Travis says we're failing:
https://travis-ci.org/drapergem/draper/builds/3717738 and a rebuild
https://travis-ci.org/drapergem/draper/builds/3717738

:'(

Do the tests run for you, @nashby https://github.com/nashby @haines
https://github.com/haines ?


Reply to this email directly or view it on GitHub
#392.

Owner

steveklabnik commented Dec 18, 2012

Ahhhhhhhhh. Let me tie down that version, then, and investigate.

Owner

steveklabnik commented Dec 18, 2012

Right, so this should not affect Draper users at all, just our tests. Until they're updated, I'm locking the version to 1.0.1, which is the one I'm using locally.

Owner

steveklabnik commented Dec 18, 2012

Our integration tests app isn't picking up the middleware for some reason.

@steveklabnik steveklabnik referenced this issue in steveklabnik/request_store Dec 18, 2012

Closed

Possible issue with Railtie inclusion #8

Owner

steveklabnik commented Dec 18, 2012

Okay, this is locked down so our tests pass, but this is a bug in request_store. I've filed one over there.

Owner

steveklabnik commented Dec 18, 2012

@haines made a good point, this is our fault: steveklabnik/request_store#8 (comment)

@steveklabnik steveklabnik reopened this Dec 18, 2012

Contributor

haines commented Dec 24, 2012

As @elado points out in #396, this issue breaks Draper on the console as well as in tests. I've tested my fix (steveklabnik/request_store#11) and it works for both cases.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment