Permalink
Switch branches/tags
Nothing to show
Commits on Apr 3, 2012
  1. Added --user option to `siriproxy server` to allow privileges to be d…

    drbrain committed Apr 3, 2012
    …ropped after socket creation
Commits on Dec 8, 2011
  1. Added initialize method that takes a config so plugins that don't def…

    chendo committed Dec 8, 2011
    …ine it won't break
    
    Conflicts:
    
    	lib/siriproxy/plugin.rb
Commits on Dec 7, 2011
  1. Merge branch 'refs/heads/dev'

    plamoni committed Dec 7, 2011
  2. Updated version number

    plamoni committed Dec 7, 2011
  3. Merge branch 'refs/heads/dev'

    plamoni committed Dec 7, 2011
Commits on Dec 6, 2011
Commits on Dec 4, 2011
  1. 2.3.3 Added filters preview and custom commonName

    plamoni committed Dec 4, 2011
    -Added "-n" option for "gencerts" to allow you to define the commonName (this is useful when you have multiple certs)
    -Added an early preview of filters for low level handling of arbitrary objects. Please provide feedback on these in the IRC chat!
    -Added an inspect method to the SiriProxy::Plugin class.
    -Added support for selecting a branch for plugins in the config.yml
  2. Fixed spelling error.

    plamoni committed Dec 4, 2011
Commits on Dec 2, 2011
  1. Merge pull request #104 from nolim1t/rvmpatch

    netpro2k committed Dec 2, 2011
    Added RVMRC file
  2. Merge pull request #111 from litlfred/typo

    netpro2k committed Dec 2, 2011
    Fixed typo in header comments of example plugin
  3. Fixed typo in header comments of example plugin

    litlfred committed Dec 2, 2011
Commits on Dec 1, 2011
  1. Added RVMRC file

    nolim1t committed Dec 1, 2011
  2. Second attempt to fix openssl < 1.0.0

    plamoni committed Dec 1, 2011
    Okay,  that first attempt failed. I left a "default_md=default" in there and misspelled "sha1" -- my bad. :-)
  3. Updated version number

    plamoni committed Dec 1, 2011
  4. Added default message digest for openssl < 1.0.0

    plamoni committed Dec 1, 2011
    Openssl versions prior to 1.0.0 were giving an error because they didn't have a default message digest type. I added one: sha1
    
    I believe this is how it was fixed before, but they provided md5 as the default digest type and Apple was not cool with that, causing errors when running SiriProxy.
Commits on Nov 30, 2011
  1. Merge gemify

    netpro2k committed Nov 30, 2011
    Conflicts:
    	README.md
  2. Added the ability to add a :spoken option to say and ask

    plamoni committed Nov 30, 2011
    -Example:
    
    say "Do as I write", spoken: "Do not what I speak"
    
    -Also re-fixed the ".git" errors :-)
  3. Merge pull request #89 from jamesjr221990/patch-1

    plamoni committed Nov 30, 2011
    edited the instructions to config.yml instead of config.yaml
  4. Merge pull request #88 from eMxyzptlk/gemspec_ruby_version

    plamoni committed Nov 30, 2011
    Gemspec ruby version
Commits on Nov 29, 2011
  1. Gemspec: Depend on MRI >= 1.9.3

    kalbasit committed Nov 29, 2011
  2. Revert "Merge pull request #75 from ErebusBat/gemify"

    plamoni committed Nov 29, 2011
    This reverts commit c403cde, reversing
    changes made to 82aaa99.
    
    (the changes to gen_certs.sh were breaking cert generation).
  3. Fixed `'s in readme.

    plamoni committed Nov 29, 2011
Commits on Nov 28, 2011
  1. Merge pull request #75 from ErebusBat/gemify

    plamoni committed Nov 28, 2011
    Fix 0 byte ca.pem from gen_certs.sh
  2. Added "update" task to siriproxy "bin"

    plamoni committed Nov 28, 2011
    You can now update from a directory or directly from github (even specify a branch!). Great for people working on plugins who need to quickly update their code!