Forcing a specific SSL version (for use with Mechanize) #16

Closed
astera opened this Issue Feb 6, 2012 · 0 comments

Comments

Projects
None yet
2 participants

astera commented Feb 6, 2012

Ehlo,

as pointed out in http://stackoverflow.com/questions/9150032/using-mechanize-or-even-nethttp-with-ruby-1-9-returns-opensslsslsslerro, some servers might have issues with renegotiating an SSL version, and so in that case it'd be more than handy to force a specific version right away when trying to establish a connection.

This is pretty much a feature request in the way of what the Net::HTTP object's ssl_version method does - so one would be able to use that particular functionality from the Mechanize gem via net-http-persistent (like, 'agent.ssl_version = "SSLv3"').

Cheers,
/astera

@drbrain drbrain closed this in 5f4a945 Feb 6, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment