New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

New ReHLDS is not supported for Windows XP. Please fix it. #562

Open
FOXZOMBIE opened this Issue Dec 26, 2017 · 13 comments

Comments

Projects
None yet
5 participants
@FOXZOMBIE

FOXZOMBIE commented Dec 26, 2017

After Tue Jul 25 12:49:35 CEST 2017 | ReHLDS is not supported for Windows XP. Please fix it.

@Freeman-AM

This comment has been minimized.

Show comment
Hide comment
@Freeman-AM

Freeman-AM Jan 2, 2018

I can confirm it. That a fact, even if it's a bad thing to run on XP nowadays.

I have at least 2 players who can confirm crashes. One can't play at all, while the other one have random crashes.

That could be cool to be fix if it's possible.

Freeman-AM commented Jan 2, 2018

I can confirm it. That a fact, even if it's a bad thing to run on XP nowadays.

I have at least 2 players who can confirm crashes. One can't play at all, while the other one have random crashes.

That could be cool to be fix if it's possible.

@rx1983

This comment has been minimized.

Show comment
Hide comment
@rx1983

rx1983 Jan 3, 2018

I have the same problem, my server is on a Windows XP and re-hlds does not work, the same server did not my windows 7 notebook worked.

what to do ?

rx1983 commented Jan 3, 2018

I have the same problem, my server is on a Windows XP and re-hlds does not work, the same server did not my windows 7 notebook worked.

what to do ?

@WPMGPRoSToTeMa

This comment has been minimized.

Show comment
Hide comment
@WPMGPRoSToTeMa

WPMGPRoSToTeMa Jan 3, 2018

Contributor

Can you find the exact commit that created this issue?

Contributor

WPMGPRoSToTeMa commented Jan 3, 2018

Can you find the exact commit that created this issue?

@rx1983

This comment has been minimized.

Show comment
Hide comment
@rx1983

rx1983 Jan 5, 2018

"commit", not undertand you ?

rx1983 commented Jan 5, 2018

"commit", not undertand you ?

@WPMGPRoSToTeMa

This comment has been minimized.

Show comment
Hide comment
@Freeman-AM

This comment has been minimized.

Show comment
Hide comment
@Freeman-AM

Freeman-AM Jan 6, 2018

I'm monitoring the client bug, i have an old hdd with no reason in life, just setup XP on it.

Freeman-AM commented Jan 6, 2018

I'm monitoring the client bug, i have an old hdd with no reason in life, just setup XP on it.

@Freeman-AM

This comment has been minimized.

Show comment
Hide comment
@Freeman-AM

Freeman-AM Jan 7, 2018

Concerning the client bug, i though at first it was related to rehlds/regamedll because long time ago i used to play on regular hlds hosted on linux with a windows XP client and i had no problem at all. But the reason of the crash was completely stupid. I tasked one of my admin to do a better motd.txt for the server. He included a logo as an image link in https and that was the only reason why people crashed with windows XP on my server. Windows XP CS 1.6 client (valve one) just don't support https link i believe. I switched back to an http link and now the logo is displaying and don't lead to a crash under windows XP.

I didn't tested under regular hlds but i have no doubt it will also crash.

So XP users can now come back to my server.
The issue is closed for my part.
The opener should see if the problem is similar.

Concerning the issue about running rehlds under windows XP, i won't monitor it because i don't have the time to do so. Plus it's not recommended to simply run windows XP, so a server... You get my point of view. xD

Freeman-AM commented Jan 7, 2018

Concerning the client bug, i though at first it was related to rehlds/regamedll because long time ago i used to play on regular hlds hosted on linux with a windows XP client and i had no problem at all. But the reason of the crash was completely stupid. I tasked one of my admin to do a better motd.txt for the server. He included a logo as an image link in https and that was the only reason why people crashed with windows XP on my server. Windows XP CS 1.6 client (valve one) just don't support https link i believe. I switched back to an http link and now the logo is displaying and don't lead to a crash under windows XP.

I didn't tested under regular hlds but i have no doubt it will also crash.

So XP users can now come back to my server.
The issue is closed for my part.
The opener should see if the problem is similar.

Concerning the issue about running rehlds under windows XP, i won't monitor it because i don't have the time to do so. Plus it's not recommended to simply run windows XP, so a server... You get my point of view. xD

@WaLkZa

This comment has been minimized.

Show comment
Hide comment
@WaLkZa

WaLkZa Jan 7, 2018

@WPMGPRoSToTeMa i have tested on my old PC with XP and i can confirm 9b75935

WaLkZa commented Jan 7, 2018

@WPMGPRoSToTeMa i have tested on my old PC with XP and i can confirm 9b75935

@WPMGPRoSToTeMa

This comment has been minimized.

Show comment
Hide comment
@WPMGPRoSToTeMa

WPMGPRoSToTeMa Jan 7, 2018

Contributor

@WaLkZa do you mean the server?

Contributor

WPMGPRoSToTeMa commented Jan 7, 2018

@WaLkZa do you mean the server?

@WaLkZa

This comment has been minimized.

Show comment
Hide comment
@WaLkZa

WaLkZa commented Jan 7, 2018

yep

@WPMGPRoSToTeMa

This comment has been minimized.

Show comment
Hide comment
@WPMGPRoSToTeMa

WPMGPRoSToTeMa Jan 7, 2018

Contributor

@WaLkZa so, the server just crash or something else? Did you try just rehlds without metamod and regamedll?

Contributor

WPMGPRoSToTeMa commented Jan 7, 2018

@WaLkZa so, the server just crash or something else? Did you try just rehlds without metamod and regamedll?

@WaLkZa

This comment has been minimized.

Show comment
Hide comment
@WaLkZa

WaLkZa Jan 7, 2018

Yes. It's a clear 6153 build with replaced rehlds dlls.
9240231h

WaLkZa commented Jan 7, 2018

Yes. It's a clear 6153 build with replaced rehlds dlls.
9240231h

@rx1983

This comment has been minimized.

Show comment
Hide comment
@rx1983

rx1983 Jan 8, 2018

@WaLkZa so, the server just crash or something else? Did you try just rehlds without metamod and regamedll?
yes, only re-hlds.... and crash

rx1983 commented Jan 8, 2018

@WaLkZa so, the server just crash or something else? Did you try just rehlds without metamod and regamedll?
yes, only re-hlds.... and crash

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment